cancel
Showing results for 
Search instead for 
Did you mean: 

Maximus X Hero BIOS 1602

reupens
Level 7
BIOS 1602 is now out.
1. Improve system performance.
2. Support the latest 8th Gen Intel® Core™ Processor.


It's still propagating on the support site, so it's only showing for some operating systems.

HERO download:
http://dlcdnet.asus.com/pub/ASUS/mb/LGA1151/ROG_MAXIMUS_X_HERO/ROG-MAXIMUS-X-HERO-ASUS-1602.zip

HERO Wi-Fi AC download:
http://dlcdnet.asus.com/pub/ASUS/mb/LGA1151/ROG_MAXIMUS_X_HERO_WI-FI_AC/ROG-MAXIMUS-X-HERO-WIFI-AC-A...
37,787 Views
114 REPLIES 114

NemesisChild wrote:
Sames results, with both XMP profile and manual settings.


This is the first bios that the Raja 4133 preset wouldn't boot on the Apex for me.
One of the reasons I prefer the Extreme or Apex boards there are more memory presets in the bios, some very high voltage for LN2 use but last couple models Raja included a very good preset for high speed, tight timing, daily use, worth the price of the board to me

Menthol wrote:
This is the first bios that the Raja 4133 preset wouldn't boot on the Apex for me.
One of the reasons I prefer the Extreme or Apex boards there are more memory presets in the bios, some very high voltage for LN2 use but last couple models Raja included a very good preset for high speed, tight timing, daily use, worth the price of the board to me


That's pretty cool actually, do you know if the MX Code has Raja's RAM presets as well?

Menthol wrote:
While everyone's bios settings need to be tested individually mostly due to variables in CPU and other hardware and peripherals more so than the motherboards themselves we don't call each other names or disrespect one another on this forum

That said on my Apex this is the first bios that does not want to run my memory kit at 4266 cl17 with 1t timings, I have to run 2t


Yeah.. same problem... and not just this.. however i can post way higher Mhz

bass_junkie_xl
Level 11
hmmm im a stick to 1403 i guess
Rig # 1 - 14900Ks SP-118 | 87 MC @ 6.0 GHZ | 5.2 R | 4.7 E | DDR5 48GB @ 8,600 c36 | Strix RTX 4090 | PG27AQN 1440P 27" 360 Hz G-Sync ULMB 2

Rig # 2 - 14900K-SP-120 | 89 MC @ 5.9 GHZ | 5.2 R | 4.7 E | DDR4 32GB @ 4,300 c15 | Strix RTX 3080 | Aoc 1080P 25" 240 Hz G-Sync

Zammin
Level 9
I have just switched to BIOS 1602 on my MX Code, was disappointed to see that my overclocking profiles were deleted as part of the process This might be normal but I recall that the last time I upgraded the BIOS on my old MX Hero all my overclocking profiles were retained. Luckily I backed up my 5Ghz profile to a USB prior to the upgrade, although it failed to load the .CMO file after the upgrade, so I had to manually enter my settings again using the .txt file.

No issues running AIDA64 or RealBench on this version for me.

Zammin wrote:
I have just switched to BIOS 1602 on my MX Code, was disappointed to see that my overclocking profiles were deleted as part of the process This might be normal but I recall that the last time I upgraded the BIOS on my old MX Hero all my overclocking profiles were retained. Luckily I backed up my 5Ghz profile to a USB prior to the upgrade, although it failed to load the .CMO file after the upgrade, so I had to manually enter my settings again using the .txt file.

No issues running AIDA64 or RealBench on this version for me.


Haven't upgraded to this 1602 bios but I have also had the .cmo file failing to load issue a couple weeks back.. What good is backing up your profile to the USB if it won't even load after updating bios? This needs to be fixed Asus!

Pervy Jutsu wrote:
Haven't upgraded to this 1602 bios but I have also had the .cmo file failing to load issue a couple weeks back.. What good is backing up your profile to the USB if it won't even load after updating bios? This needs to be fixed Asus!


This feature only work on the same bios version, so members can easily share bios settings, etc.
Due to differences between versions the same settings may not work so you will have to manually enter settings after updating. You can save the settings in a TXT file and print it out to make it somewhat easier

hello! i have upgraded my Bios before using all the methods available, Returned a maximus hero thinking it was the MOBO when i got a dead 8700k through amazon. thinking i had terrbile luck i got my replacement board and intel refunded what i payed for my 8700k. things went smoothly since december 2017. OC's to 5.3ghz (-2AVX) 1.440 Vcore (credits to menthols' settings and patience), 3200mhz ram, prime95 tested for 24 hours. sadly after doing BIOS updates: 0802, 1003, 1101,1301,1401 (using internet through ethernet with temp cable and USB method for the last two.) my luck seeemed to run out. I tried using the revert bios with the light blinking indicating success would always get error code 22 regardless of what i do. swapped all the ramsticks to have 1 at a time each try, tried different brand. Everything was working fine before the failed bios update, i used the flash utility to try and upgrade but it died after it turned off. cant get into bios, cant revert bios etc. I have bought another MOBO and am waiting for it to come. :(. Just a heads up to everyone STAY AS FAR AWAY AS YOU CAN FROM THIS BIOS UPDATE 1602.

G_A_B_O_ wrote:
hello! i have upgraded my Bios before using all the methods available, Returned a maximus hero thinking it was the MOBO when i got a dead 8700k through amazon. thinking i had terrbile luck i got my replacement board and intel refunded what i payed for my 8700k. things went smoothly since december 2017. OC's to 5.3ghz (-2AVX) 1.440 Vcore (credits to menthols' settings and patience), 3200mhz ram, prime95 tested for 24 hours. sadly after doing BIOS updates: 0802, 1003, 1101,1301,1401 (using internet through ethernet with temp cable and USB method for the last two.) my luck seeemed to run out. I tried using the revert bios with the light blinking indicating success would always get error code 22 regardless of what i do. swapped all the ramsticks to have 1 at a time each try, tried different brand. Everything was working fine before the failed bios update, i used the flash utility to try and upgrade but it died after it turned off. cant get into bios, cant revert bios etc. I have bought another MOBO and am waiting for it to come. :(. Just a heads up to everyone STAY AS FAR AWAY AS YOU CAN FROM THIS BIOS UPDATE 1602.


Should we stay away from Bios 1602 wich is working fine.....or should we ignore your post? Failed bios? You made an error updating BIOS and now you are blaming ASUS for your error.

Post edited. Keep it friendly guys. Stay passionate, less hostility and mockery, please. Thanks.

emsir wrote:
Should we stay away from Bios 1602 wich is working fine.....or should we ignore your post? Failed bios? You made an error updaring BIOS and now you are blaming ASUS for your error. That's hillarious!
If you don't know how to update BIOS, let someone who knows how to do it, help you.

Think about what you have done.....Returned a Maximus Hero, THINKING it was the MOBO......Have you ever thought about maybe the problem is YOU? Now you have waisted ASUS time and money, thinking ASUS was the problem. Next you think Intel is the problem.......You are a pain in the as*.

Bro...think you have previously been warned about the context in your posts...If. you have nothing meaningful to post ...suggest you don't and therefore keep your belittling comments to yourself....
Suggest a moderator to ban this individual from further postings
Asus ROG Maximus XI EXTREME
Intel i7 9900K OC'D @ 5.2 GHZ @ 1.345V (1.296V LOAD) LLC 6 PRIME 95 STABLE 8 HRS
XSPC RX360 Rad (6)Scythe Gentle Typhoon 1850 RPM Fans In Push/Pull @ 1500 RPMS
Swiftech Drive II / Swiftech MCP35X Pump
Enermax Platimax 1200 Watt Power Supply
32GB G.Skill F4-3866C18Q-32GTZR 3866 MHZ CL18 1.35V (OC 4266MHZ 17-18-18-41-2T @1.45V)
MSI GTX 1070 SEA HAWK EK X SLI WITH ASUS HB RGB
(5)Samsung 840 Pro 128 GB In Raid 0
(2) WD 1TB Black Edition
Corsair 900 D