cancel
Showing results for 
Search instead for 
Did you mean: 

Maximus Hero X - What happened to bluetoth???

pit_ns
Level 8
Hi Guys,

I have Maximus Hero X Wifi version and I am not sure what happened but bluetoth just disappeared. There is nothing in device manager or windows itself.

I am on windows 10, checked bios and it is the latest and bluetoth is enabled.

I tried to install the drivers from asus website but i see message: "Realtek Bluetooth is not installed on your system" and then it just exists.

I have also one unknown device, no idea what that might be, tried to make windows update drivers, removed it, nothing worked to...

I have no idea what is going on here....

Is anybody else experiencing the same issue.

Any help appreciated.

I am not sure but maybe the latest bios broke something....

When i run Troubleshooting for it in windows i get below message on screenshot.
4,855 Views
2 REPLIES 2

Silent_Scone
Super Moderator
Have you tried going to the details tab, uninstalling driver or 'rolling back' if the option is present?
13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Yes. I tried all of that.

However, i found on internet to disconnect the power from power supply completely.

Which i tried yesterday, today in the morning i turned my PC back on and guess what???

Bluetooth is present again, i am thinking after Bios was updated that might have been a required step or something.

Anyways, seems to be fixed now.

Hope it also helps somebody in the future 🙂

Cheers.