Showing results for 
Search instead for 
Did you mean: 

I'm going crazy, I think I broke my USB port(s) somehow.

Level 7
I don't know anymore. Been at this for a week now.
First of all, I noticed my pc boot time wasn't amazing. In task manager my bios time was around 22 seconds every time.
My windows boot time is great, about 2 seconds after the bios is done, windows is up, so I figured, okay, somethings wrong with the bios, let’s try an update.
I then started with writing down my important bios settings, which isn’t much, I’m currently not overclocked, only XMP2 enabled, some fan settings etc. Nothing special.
I was at bios 1105 at that point, and went to 1302.
So then all hell broke loose. No more booting to windows, got an error about GPT header corruption, and how to fix it. So I tried and tried again to fix it with the bios recovery function, but that didn’t do anything.
So then I looked at some settings, and found the sata mode setting, and figured, guess I’ll try optane/raid instead of ACHI. And bam, booted to windows and everything was good again.
(Guess I should note at this point I have had raid enabled a few months ago to experiment with ssd caching. Didn’t work great, turned it all back off and raid is not enabled on any drive at all.)
However, now, my bios time was at 35 seconds every time. Whatever I did, I couldn’t get it down at all. Also, I noticed some strange usb behavior. My external HDD kept showing up at every boot (like I just connected it) and my Oculus rift headset got some strange problems with the sensor usb’s only seeing usb2 in stead of usb 3, etc. I tried to fix all those things, in device manager one of the usb busses had the yellow checkmark and updating drivers didn’t give me anything new, so I did what I always do and uninstalled that device and rebooted. It usually fixes things. Not now though, usb problems all staid the same.
So then I was at the point I had many usb problems, and a 50% slower bios boot time, so I was done. I went back to 1302. Guess I’ll live with the 22 sec boot then right?
Booted instantly again, however, I checked, this bios automatically had selected raid/optane in stead of AHCI, so it booted. When I went to AHCI, it gave me the same error again. Fine, I’ll stay at the raid setting even though I don’t run raid. No problem, right?
However, at this clean 1302 bios, with all settings like they always were before, the USB problems staid exactly the same. And then they got worse. Now, my external HDD won’t be detected at all anymore, it won’t pop up at boot either. Unless I run a system recovery, then it boots once, and after any reboot it’s gone again. If I switch it to a different port, the HDD works, and if I plug a different device in that port it also works. So I broke a driver somehow?
So I broke that port / HDD combo somehow. And it might have something to do with HDD/raid settings, maybe? Or maybe with bios settings? I have no clue anymore. I usually think of myself as pretty good with computers, but I’m stumped now. And going crazy, and feeling like I want to toss the whole pc out the window.
And no, reinstalling windows is not an option right now because of time limitations.
Also turning XMP off / to XMP1 doesn't change anything.
Oh yeah, also, after all this, my bios time is now at 12 seconds, at the 1302 bios. Also, that happened when the ext HDD broke, before that, on this clean install, it was around 30 seconds.

Basically I would like to find out:

-How to fix my usb driver(s) so the external HDD works in the old port again.

-How my bios boot time is randomly changing from 22/30/now 12 seconds all on the same bios/same settings.

-If this has something to do with my previous raid settings I tried a few months ago (and turned back off). Since I still need raid enabled in the bios to even boot to windows.

I hope someone has any idea what I’m talking about and can help me somehow. Because I’m going mad.

Maximus XI hero Wifi
64GB G.Skill Trident Z RGB F4-3200C16Q at XMP2 to run it at native 3200mhz.
I7 9700k not overclocked atm
Many drives (NVME / SSD / HDD / EXT HDD for backups)

If you didn't explictly do so I would reset to default settings in the BIOS. You may have some lingering changes from the tweaking you were doing.

I would download drivers from ASUS and reinstall them just in case it is better than what Windows is installing.

Beyond that you may want to try a USB bootable OS to see if it's Windows corruption or a physical problem with the port. You can boot Ubuntu without changing your system permanently.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

Same happened to me flashing 1302 and going back to 0602. The USB port next to the USB-C port is dead now.

SuperSpeed 7 Ports USB3.0 PCI-E Expansion Card Adapter PCI-E USB 3.0 HUB Controller

Ebay or Amazon Newegg
You can get a PCIe expansion card under 25.00 for 7 Port. I bought a 5 port with USB type a and 1 USB C Power plugs into the card. I bought 1 So I could quick getting USB error from My asus ROG Strix. I also had errors on my ROD maximus Hero X with Wi-Fi. so come with M2. SATA and PCIe if you have use up the SATA ports. You will loose the use SATA port 1 and also SATA port 5 & 6. Since I install the add-on card have no more USB errors. Hope this helps

Level 7
I did the optimized default settings. I did reinstall board drivers, the port is still broken.
I know I can add a USB card, but that's not really an option for me with a case in the middle of the living room with a glass side panel. All the good cards are red..