cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot Access BIOS on ASUS ROG STRIX Z390E Gaming

Jtepper9
Level 7
Hello All.
This is the hardware:

Asus ROG STRIX Z390E Gaming
Intel i9-9900KF
EVGA Hybrid RTX 2080 Super FTW3
G.SKILL TridentZ RGB 32GB (2x16) F4-3600C16D-32GTZRC
Samsung 860 Pro 256GB SSD

(please let me know if any other info is needed.

When I first got this mobo I put everything together and the system was able to boot into my OS (Windows 10) though it skipped the ASUS splash screen and BIOS cue. I tried multiple times to access the BIOS through restarts and through Windows advanced restarts but had no luck. Whenever I would hold down F2 or Delete or click these buttons repeatedly, the computer would freeze on startup and the BOOT LED debug light would remain lit until I turned the machine off. I called technical support and they advised me to remove CMOS battery and reinsert after a few minutes. After trying that, I was still unable to access BIOS but I was also unable to boot into my OS. Thinking I may have gottena dud with some kind of booting issue, I returned the mobo to the retailer and exchanged it for an identical one. This new mobo has demonstrated the same behavior with me unable to access BIOS no matter what method I try. I have tried to replace the ram to see if they might not be working correctly but the brand new ram I got from the store didn't seem to help at all. I haven't tried to remove the CMOS battery from this new board because of how it rendered my last one nearly useless. Any help would be much appreciated. I'm very much at a loss and would hate to have to return or RMA this one as well.
11,256 Views
1 REPLY 1

Enderwiggin03
Level 7
Unplug the power supply from the back of the PC, hit the power button for about 10 seconds or so, plug it back in, and retry it. If that doesn't work, try CMOS reset.