Showing results for 
Search instead for 
Did you mean: 

Can't upgrade to Windows 11 due to kabylakepch-hsystem.inf not being updated.

Level 8
I have a Maximus X Hero with a 8700K processor.

Below is what I get in the SetupDiagResults.log following an attempt to upgrade to Windows 11. This is the only error I get in the log which apparently is preventing me from upgrading? According to this I should either update the driver or remove it.


Error: Found a device installation failure during device install phase.
Device Installation failure detected!
Device Description: PCI\VEN_8086&DEV_A2A1
HardwareId: PCI\VEN_8086&DEV_A2A1&SUBSYS_872F1043&REV_00\3&11583659&0&FA
Inf Name: kabylakepch-hsystem.inf
Driver Version:

Recommend you update the driver package or remove the device and drivers, and try again.


Asus EZ Update has been telling me for a while now that I can update the Intel Chipset Driver from to but after updating it, it still gives me the same message that I need to update it.


I installed Intel Driver Support Assistant and it tells me I'm up to date.
I tried searching on Intel's website for the latest Z390 drivers, found this link ...
tried running their ..ME_SW_MSI\SetupME.exe but I it fails and when I check the logs it has a 1603 error.



Driver Store Explorer shows me the following versions.


I have a 8700K CPU, so this is Coffee Lake not Kaby Lake, correct? Why do I need Kaby Lake drivers on my PC?
So I tried deleting the kabylakepch-hsystem.inf driver from within Driver Store Explorer but I get an error saying the driver may still be in use. Try FORCE delete. How do I force delete? And should I even be deleting this driver?



And note my BIOS is at Version 2701

Any help would be appreciated. Thanks.

MoKiChU wrote:

Don't install the Chipset drivers from Windows Update - Optional updates, this is what caused your issue.

They are recognizable by their dates which are other than the 07/18/1968 (Note from Intel : Intel(R) Chipset Device Software uses an unusual date for the devices it is targeting. The date 07/18/1968 is symbolic - Intel was founded that day) :

Since you installed the Chipset drivers from Windows Update - Optional updates, follow this process :

- Uninstall your current Intel Chipset Drivers package if you have any installed (via Start > Settings > Apps) then restart your PC.
- Launch Driver Store Explorer (Right click on "Rapr.exe" > Run as administrator) > Check the boxes of all versions of drivers which .inf ending with system in the System device category (if you find them).
- Check the box "Force Deletion" then click on the "Delete Driver" button then restart your PC.
- Install the latest Intel Chipset Drivers package from the first post of this thread : [DRIVERS] Intel Chipset/MEI/SATA/VMD (1xx/2xx/3xx/4xx/5xx/6xx/7xx).

Also, you need these firmware/drivers for your ASUS ROG Maximus X Hero (Wi-Fi AC) motherboard :

[FIRMWARE] Intel ME (H110/B150/H170/Z170/B250/H270/Z270/B365/Z370)

[DRIVERS] Intel Chipset/MEI/SATA/VMD (1xx/2xx/3xx/4xx/5xx/6xx/7xx)

- Intel Chipset Drivers

- Intel MEI Drivers (Drivers Only)

- Intel SATA AHCI-RAID Drivers (Drivers Only) :

Drivers - 2xx/3xx

[DRIVERS] Intel Ethernet/WiFi/Bluetooth

- Intel Ethernet Drivers (Drivers Only) :

Drivers - I217/I218/I219

[DRIVERS] Realtek Ethernet/WiFi/Bluetooth

- Realtek WiFi Drivers (Drivers Only) :

Drivers - 8723DE/8821CE/8822xE

- Realtek Bluetooth Drivers (Drivers Only)

[DRIVERS] Realtek Audio (Intel 2xx/3xx/4xx/5xx/6xx/7xx & AMD 3xx/4xx/5xx/6xx)

You have an ASUS ROG SS3 motherboard, so :

You need Realtek Audio Drivers (UAD - ASUS ROG SS3) from the first post of the thread.

Follow scrupulously your CLEANUP process then your INSTALL process, for the next drivers packages that I would release, you will can directly follow your UPDATE process.

Thank you so very much. Honestly, great work!