Showing results for 
Search instead for 
Did you mean: 

Bluetooth suddenly stopped working

Level 7
I have a ROG STRIX Z370-E GAMING that I've been running for just over a year. It's always worked great. Then suddenly this morning the Bluetooth stopped working.
It was working yesterday, but now the BT icon is gone from the tray, and when I go into BT settings, the toggle on/off switch is missing. I'm on WIndows 10 x64.

All my BT paired devices are still listed. BT is enabled in the BIOS (I didn't change anything).

The BT taht's built into my Vive is still listed in device manager, but that's separate from the on-board and can't be used for anything other than controlling the lighthouses.

Here's what I've tried to troubleshoot it:

Downloaded newest drivers from ASUS and installed - chipset, wifi, audio, and BT. The ASUS BT drivers just complain that BT isn't enabled, so they never install.

Rebooted into BIOS, turned off BT, updated firmware, re-enbaled BT => no change - BT still not showing.

I unplugged the Vive completely so now no BT devices show up in device manger.

I do now notice in Device Manager, under USB controllers, there's an item labelled "Unknown USB Device (Device Descriptor Request Failed)". I don't know if it's related, but the only events listed for it are from yesterday at 4 am (I would have been in bed, so maybe a windows update ran). The events say "Device not migrated due to a partial or ambiguous match". If I remove it and scan for new hardware it pops back up with exactly the same error events.

UPDATE: If I disable BT in the BIOS, this item goes away. So... hardware problem?

Any suggestions?

kens30 wrote:
He has a Z370 board with Realtek Bluetooth not Intel.
Latest driver is 1.5.1012.3 for Win RS4 and 1.5.1014.3003 for RS5

Try to reset cmos then load optimized defaults in bios save and exit.
Once in windows shut down your pc and remove your psu from the wall then keep pressing power button to drain all power from your pc.
Wait at least 10 to 15 minutes then plug back in your Psu and power on your PC, if the problem is not gone try to re-flash your Bios.
Report back if your problem is fixed or not.

But i mostly think it is a Windows 10 issue.

if that does not work download DriverStoreExplorer

First Turn off Bluetooth in bios then once in Windows uninstall Bluetooth driver restart pc then run Rapr.exe as admin
From the list check boxes of any realtek Bluetooth drivers , then check the box Force Deletion then click on Delete Package.
Once deleted restart your pc and go straight into Bios and enable Bluetooth save and boot into Windows.
After a couple of minutes wait for Windows to install it's default Bluetooth driver then check your device manager again if problem is fixed .

I had a similar issue and fixed by your instructions. You are my hero, thank you so so so much man. God bless you. 😮

Level 7
It might be happening due to the outdated driver or if the Bluetooth service is disabled. Well, doesn't matter what the reason is, you can easily fix the problem. For this, you can follow the solutions given in this article: Fix Bluetooth Not Working In Windows 10