Z370 / Z390
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

5.1 sound system problem, help me

hello i connected my 5.1 system to maximus x hero, done configuration in sound options in controll panel, every speaker was producing sound on test, but when i play any sound, only front 2 speakers work and bass, rear speakers and middle one, dont do...

Weird Problem BIOS on Hero X with gfx Evga 1080 ti FW3

ok hard to explain but ill try here goes..Just got a new evga 1080 ti fw3, works fine but when i enter bios and change a setting where the computer shuts down cold and turns on EG. voltage change and so onThe computer dont turn on, motherboard leds b...

Does Z370-I support surround sound over S/PDIF optical?

It is a bit unclear when I look at the specs for the Z370-I if they have multi channel support for this motherboard over the optical output? What about Dolby/DTS-support?I'm asking because I can't get my Steelseries Wireless H headset setup with mult...

Bokai by Level 7
  • 2911 Views
  • 1 replies
  • 0 kudos

IS Asus Z370 still support U.2 SSD?

I got a Intel 750 U.2 ver and use it on my old X99 strix very nice.And i build a new Z370 platform using a Z370 Code and found that Asus Z370 DO NOT have any U.2 port.and i try to use a Hyper Kit M.2 to U.2 adaptor on the Code, and found that there a...

Asus maximus x code 5.0ghz overclock

GOT THIS BOARD A FEW WEEKS AGO AND RUNNING A SOLID 5.0 GHZ WITH 1.28V...GSKILL TRIDENT Z RGB 3600MHZ CL16 RUNNING 4133MHZ CL17@1.37V. THE DELIDDED 8700K IS 8 HOURS PRIME 95 STABLE WITH GREAT TEMPS. BOTH CPU VCCIO AND SYSTEM AGENT VOLTAGES ARE 1.15v.

70535 70536

BIOS shows only CPU fan spinning.

I have the Maximus x hero Wi-Fi motherboard and both BIOS and AI Suite 3 only show CPU fan spinning and all other fans show n/a in BIOS and 0 RPM in AI Suite 3.

Maximus X Formula and Aura problems

I downloaded the latest version of Aura software 1.05.25 and it doesn't work. This is a clean install of windows and I am running BIOS 1003.I get the following error during the installation. Can't Opem AsIO.sys!! (2)

Jsunn by Level 7
  • 2110 Views
  • 3 replies
  • 0 kudos