cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS Strix Z370-G front USB 3 problem with some more robust HDDs

jonnieZG
Level 7
Hi all!

My ASUS Strix Z370-G can not recognize some external USB 3.0 hard disks connected to the front USB 3 (via the internal USB 3.1 header). When I connect the disk, it starts disconnecting and reconnecting.

I have found out that the problem is very likely to be caused by the higher current drawn by the disk. The measured current is below 0.9A, which is well within the USB 3 specs), but the voltage drop must be causing the signals to be misinterpreted, even though they are also well in the valid TTL range of 2.7-5V.

The disk works fine when plugged in to any of the USB ports on the back of the motherboard, and it also works on the front USB 2.0 (internal USB 2.0 header).

A thinner USB 3.0 HDD that draws around 0.5A, and all of my USB 3 thumb-drives work fine on all ports.

It is strange that when I plug in the same big HDD to the front USB 3.0 using a digital USB 2.0 voltmeter that inherently acts as USB 3.0 to USB 2.0 converter - the disk works on the same USB 3.0 port (but of course, is recognized as a USB 2.0 disk).

I am waiting for a spare "USB 3.0 internal header to rear panel extension bracket" to arrive, to eliminate the problems with the cable on the case (even though it is unlikely because it is a fairly expensive case with good cables), but I had the same problem with an older Asus motherboard and a different case.

I do have the latest Windows 10 64-bit drivers, I did experiment with BIOS settings with no success.

Does anyone have a solution?
2,398 Views
1 REPLY 1

jonnieZG
Level 7
I have just found out that the problem was the contact on the motherboard. After unplugging the front USB 3 cable and plugging it back into the motherboard, one of the two USB 3 connectors started working fine, while the other is still not working properly.

I wonder if the same cable work work better with a different vendor motherboard, and how a different cable would work on the same motherboard...