cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Maximus X Apex & LSi Logic SAS1068E PCI-Ex8

Petrufel
Level 7
Hello guys, i have a strange issue.

I have a server based on Asus Maximus X Apex
https://www.asus.com/Motherboards/ROG-MAXIMUS-X-APEX/
Bios 0401 x64

There is a strange issue with this SAS controller PCI card:
LSi Logic 8xSAS SAS1068E 2xSFF8087 RAID 0/1 PCI-Ex8
74149
It is detected in Ubuntu 16.04 lspci as SCSI storage cpntroller: LSI Logic / Symbios Logic SAS1068E PCI-Express Fusion-MPT SAS (rev 08).

Issue:
When I do connect any other PCI card with the LSI controller (for example graphics adapter or network adapter) - it does not boot the LSI card bios, and looks like not recognized at all. No hard drives are detected, of cource.


  • When I do connect LSI card in any PCI slot by itself, no other PCI cards installed - it works perfectly every boot. Mo matter if it is PCI x4 x8 or x16 slot.
  • When there is other card installed, LSI card have the power, LEDs glowing as well as in case it boots.
  • I tried all kind of PCI slots, and reordering. It looks like it does not matter.
  • All PCI slots are switched ON with the swithes on the moterboard.
  • When there is either video adapter installed or network adapter alongside or both with LSI, they do work properly, while LSI is not.
  • I tried to boot the server on 920W power supply. Originlly it was running on 500W 80 Plus Platinum power, so i dont think there is a lack of power supply.


The other sever on Asus Rog Strix Z370E Gaming mobo, with slightly different LSI card but on the same chip, and system does detect LSI and boots LSI bios well, even with network adapter installed in PCIe x16 slot alongside with SAS card.
The LSI card is detected also as SCSI storage controller: LSI Logic / Symbios Logic SAS1068E PCI-Express Fusion-MPT SAS (rev 08)

I tried to borrow LSI card from that server that works fine - but it does not change anything. It does not boot the LSI bios if any other card is installed. So it looks like MoBo issue.

This documentation says that the LSISAS1068E can be configured as a PCI Express x8, x4, or x1 device, supporting auto-negotiation among those link widths. For example, if the LSISAS1068E is configured for 8 lanes and is plugged into a x8 connector that is wired as a x4, the LSISAS1068E will automatically negotiate to a x4 link width.
https://wiki.pdl.cmu.edu/pub/OpenCloud/CloudManuals/SCG_LSISAS1068E_PB_040407.pdf

Any suggestions?
I have a request opened in the ASUS Support, they are taking 48 hours to answer.
364 Views
5 REPLIES 5

Petrufel
Level 7
New BIOS did not help. The 1301 x64

Raja
Level 13
I’d go through ASUS support for this. There is a reason server and workstation boards command a price premium and have validation lists for controller cards. Enthusiast motherboards are primarily validated for consumer peripherals.

Petrufel
Level 7
Raja, thanks for your answer, I do wait the tech support to reply.

I would buy a z370 server mobo but unfortunately there is no such card as far as I know.

The 8700k gives more ghz per core than server CPUs and z370 mobos can run DDR4 on higher frequencies, that gives a better machine for my applications.

I chose ASUS MAXIMUS X APEX as it runs my Corsair DDR4 on 4400mhz with no problem, while Asus Rog Strix Z370E Gaming did only 3700mhz on memory tested as 4Ghz.

Strange that Asus Rog Strix Z370E Gaming have no such issue, while it is obviously not a server Mobo. Isn't it?

Petrufel wrote:


Strange that Asus Rog Strix Z370E Gaming have no such issue, while it is obviously not a server Mobo. Isn't it?


That's what you're playing with when you don't buy a server or workstation board/platform that doesn't have your chosen peripherals in the qvl. It may work, it may not. And there's no guarantee it will work on every bios version. These are compromises one has to expect when running a mission critical system without confirming compliance before putting it together.

Petrufel
Level 7
I'll take a closer look on different brands now. This conntroller is like 10 years old. Its the basic thing.