Showing results for 
Search instead for 
Did you mean: 

AMD Ryzen 7 3700X and ROG STRIX X570-E Gaming build severe problem

Level 7
Motherboard model: TUF Gaming X570-Plus AND ROG Strix X570-E Gaming
UEFI Version: 2407
CPU: Ryzen 7 3700X
Memory kit part number (s) and amount in GB: Corsair CMW32GX4M2C3200C16 32GB
GPU: Gigabyte GeForce GTX 1050 4GB
SSD/HDDs/Optical drives: 500 GB Samsung 850 EVO, 1TB Samsung 860 EVO, no optical
PSU: Corsair HX850 850w
USB Devices (model/version number): Microsoft Keyboard, Logitech Mouse
Monitor: 2x Dell 23" 1080p monitors

CPU Cooler: Wraith PRISM heatsink+fan
PC CASE: Fractal Design Focus G
Operating system: N/A (Will be Windows 10)

Drivers Installed (include version): N/A
Any third Party temp/voltage software installed: None
System Overclocked (provide details)? No


I am at my wits end. I have tried everything I can think of and nothing has worked. I am on my second CPU, second motherboard, AND second set of RAM. I have tried two different PSUs, two different GPUs, and adjusted memory timings. Only one hard drive ever gets beyond POST which is just so bizarre. The ONLY way to consistently change the behavior of the system is to change hard drives. I have no idea what is wrong - I need some serious help.

The PC boots every time, I can enter the BIOS and adjust settings. Without an SSD connected, I can load Live/Pre-installation versions of Ubuntu and Windows from USB flash drives without issue; I have run diagnostic tests (Memtest, CPU stress tests, SMART diagnostics) this way. The machine will also enter Windows setup and I can make it all the way to the screen in which you choose the drive to install windows.

I have ONE hard drive that will get past POST - a Samsung 850 EVO 500GB SSD. I can boot from a flash drive into Windows setup. I can boot from a flash drive and enter Windows 10 Pre-Installation environment. I can not format the SSD - the machine reboots every time. I also can not run diagnoistic tests otherwise the system reboots.

No other hard drive will get past POST. I have pulled hard drives (SSDs and HDDs) from other, working systems, plugged them into this new system, and it will not POST - it will just hard reboot every time. All the hard drives that cause my new system to reboot work on my other computers - I can format the drives, run diagnostic tests, and copy files to the SSDs on other computers. If I plug them into my new system, however, the system will just reboot.

I have tried EVERYTHING I can think of to fix this problem. The weirdest thing is that I have the same problem with TWO DIFFERENT ASUS MOTHERBOARDS! I have already RMA'd the CPU once to Newegg . It's possible they just resent the same CPU back to me, but I have no way to know - I didn't copy the serial number from the original CPU.