Showing results for 
Search instead for 
Did you mean: 

All USB ports not working after restart (Strix-e)

Level 7
I installed microsoft VC redist 2008 edition trying to get a program to work it prompted me to restart the pc, on boot all USB devices ceased functioning, I am unable to enter the bios or do anything at all with the computer, I went and bought a PCI USB card no luck with that either. The ports have power apparently since it charges my phone, yet none of my devices light up at all when plugged in, the keyboard mouse, ect nothing indicating they have power. Everything else turns on fine, takes me to the american megatrends screen and says no keyboard detected along with 0 keyboard 0 mouse 0 hub ect. I am going to RMA the board but I am trying everything I can think of before I have to. Really wish ASUS put a damn PS/2 connector on the board.

Any ideas of what the hell could possibly be going on? Everything was working perfectly before hand no signs of trouble prior.

Never had problems with this rock solid MB then my USB keyboard wouldn't work after a restart. Thought it was a fluke.

ASUS STRIX Z370-F GAMING I bought this motherboard assembled with cpu and cooler, everything fine for 11months then I shut down the computer in the normal way, then rebooted a few hours later to find no usb ports working appart from the single usb 3.0 port, I contacted the suppliers as the board is still under warranty. The suppliers Scan Computers UK told me to reinstall the motherboard drivers which I did, but sadly made no difference so they told me to send it back to them and they would check it out as they have a technical department and would get the board fully working or supply a replacement. I await the result.
I posted this issue because I have noted a quite a few people have been having this problem with a number of Asus motherboards.

After one year with a MB ROG Strix Z370-E Gaming all USB ports except USB3.1 stopped to work as have been described here. The USB3.1 worked with a USB hub for KB and mouse in the Bios but not in Windows. The OS was therefore locked for any activity. Since the problem obvious is a common one ASUS ought to have a good solution now. I hope and expect ASUS to come come up with a very good explanation what to do.

On bios settings there's choice to use either 3.1 or usb 2.0 , it says clearly on bios that is one is used it closes other meaning if you want to use 3.1 usb you can't use 2.0 as they exclude each other.

Janny805906 wrote:
On bios settings there's choice to use either 3.1 or usb 2.0 , it says clearly on bios that is one is used it closes other meaning if you want to use 3.1 usb you can't use 2.0 as they exclude each other.

To be crystal clear: the keyboard and mouse worked well one year on USB2.0 when then suddenly dropped dead. Any attempt to reconnect did not work including battery reset, change of keyboard and mouse and more. The keyboard and mouse was not recognised i.e. no keyboard was detected by the Bios. So, after trying the USB2.0 connection the 3.1 was tested and it worked in the Bios but not in the OS. So nothing had to do with using USB2.0, USB3.0 or USB3.1 at the same time simply because USB2.0 and USB3.0 didn't work. So, what's the logic? Whatever USB connection port that was used, OS didn't recognise KB or mouse. My problem or south bridge problem or what?

Okay, I'm a bit late to the discussion it seems, in my case I'm facing somewhat similar issue but for me the USB ports aren't completely dead. When I power on my system during POST the keyboard gets detected but it simply goes dead as soon as the OS starts loading (Windows 10 B1903). However, after multiple random reboots the OS does boot up with the USB ports (KB and Mouse) working.

As a workaround I have noticed that putting the system to Sleep rather than shutdown/hibernate, the USB ports remain in a working state. Not ideal but for now this seems to be working till I can find a fix.

CPU: Intel 4790
RAM: HyperX Fury DDR3 1600

Any suggestions are welcome and appreciated.


Level 7
I cant make any changes, I can't get into the bios. NO usb ports are working at all, I restarted my working computer and on boot all usb ports stopped working, I tried resetting the cmos and all that stuff removing ram, all usb connections besides keyboard and mouse, everything. I have no USB connectivity at all. So after resetting the bios by using the battery removal technique it wants me to enter the bios, I cannot I have no usb capability. I have tried everything to get the mobo to pick up a usb device and nothing works. Even tried a pci usb card. All the USB ports are dead.

Level 13
Read my edited post above, please.

Level 7

I am facing same kind of issue since 2 days. I restarted the PC after a game update. Since then usb not working

Mobo - Asus B365F gaming

All usb ports not worked after boot, suddenly Now All ports not working even when booting ( can’t access bios)