cancel
Showing results for 
Search instead for 
Did you mean: 

5.1 sound system problem, help me

Zfast4y0u
Level 7
hello i connected my 5.1 system to maximus x hero, done configuration in sound options in controll panel, every speaker was producing sound on test, but when i play any sound, only front 2 speakers work and bass, rear speakers and middle one, dont do nothing.

i have installed every possible driver out there, updated and still no fix. this is annoying. should be stright forward >_>

anyone know how to fix this? i wanna use my 5.1 damn it.
3,145 Views
6 REPLIES 6

toronto699
Level 13
I have Same issue, The Problem seems to be with W10, 5.1 will only work if the source is 5.1 or the source is up mixed to multi speaker
There are many Posts about 5.1 not working

toronto699 wrote:
I have Same issue, The Problem seems to be with W10, 5.1 will only work if the source is 5.1 or the source is up mixed to multi speaker
There are many Posts about 5.1 not working


well thats just great.

should we expect fix from microsoft any time soon?

is this issue just with this particular mobo or is it wide spread on win 10?

toronto699
Level 13
All MB unless they have 5.1 software ,Most Manufacturers Do Not Want To Pay a Royality Fee for 5.1 as an example Cyberlink DVD will play 5.1 through software ,and W10 no longer has Speaker Fill included in the Drivers
So basically we are missing Speaker Fill In W10 and in W10 Drivers
Sometimes I use this free software to get 5.1 , although its for a head set seems to work free version . try if u like
https://www.razerzone.com/surround

Best Solution Is Buy A Creative Labs Sound Card

toronto699 wrote:
All MB unless they have 5.1 software ,Most Manufacturers Do Not Want To Pay a Royality Fee for 5.1 as an example Cyberlink DVD will play 5.1 through software ,and W10 no longer has Speaker Fill included in the Drivers
So basically we are missing Speaker Fill In W10 and in W10 Drivers


so its safe to say, i can box my 3 speakers and go 2.1? -.-

toronto699 wrote:
All MB unless they have 5.1 software ,Most Manufacturers Do Not Want To Pay a Royality Fee for 5.1 as an example Cyberlink DVD will play 5.1 through software ,and W10 no longer has Speaker Fill included in the Drivers
So basically we are missing Speaker Fill In W10 and in W10 Drivers
Sometimes I use this free software to get 5.1 , although its for a head set seems to work free version . try if u like
https://www.razerzone.com/surround

Best Solution Is Buy A Creative Labs Sound Card



i have one, very old one, +10 years, but its not near me atm. so im stuck with this onboard crap. im big fan of creative sound cards, i have used em always and avoided onboard sound like plague cause of problems like this.

toronto699
Level 13
I have Asus Sonic Suite it has Upmix but I cannot get the software to work , even though my Default Audio is Realtek , Asus seems clueless with the Sonic Suit issue as well