cancel
Showing results for 
Search instead for 
Did you mean: 

2004 BIOS - ROG MAXIMUS XI series

Vassilis008
Level 7
Version 2004
2021/11/29 8.19 MBytes
ROG MAXIMUS XI HERO (WI-FI) BIOS 2004
"1. Update Intel ME firmware.
2. Improve system stability

Everything working well for me so far after the update 🙂
1,943 Views
20 REPLIES 20

zone
Level 7
Thanks for sharing your success. I've been putting off the update until I hear some experiences.

Wangeyed
Level 9
all fine here so far z390-f

zone
Level 7
Always load your optimized defaults before flashing. I know better. I got lazy. It bit me on this one. Luckily nothing I couldn't fix with the clear cmos button and then manually resetting my profile, but don't be me.

For a long time there is a problem with a long cold start (after full power off) of the motherboard. I am the owner of Hero XI, with BIOS 1302 at cold start, from power button pressing to logo appears takes about 10 sec, at 1903 and 2004 and other bios starting from about 1802 (I don't remember exactly version when it started) it takes 20-30 sec. Try change different setting with no result, maybe it is related to performing RAM training after power off, but with MRC Fast boot=enable dont change anything, with default settings we get the same result. Earlier i record video with post codes during long cold start https://youtu.be/jZqzHUL-Z-s

ROG Strix Z390-F.

This new 2004 BIOS still gives me XMP/memory issues causing POST failures on boot that 1902 and 1903 also caused. Basically I can't run my 3000Mhz memory at any frequency above 2400Mhz without this .

I've had to roll back to 1802 just to use my RAM at rated speeds again. It's all rock solid stable on 1802.

Shame really, as I'm on Windows 11 and wanted an 'official' Windows 11 BIOS along with Resize BAR.


* EDIT *

Seems like the exact issue (for me at least) is that BIOS 1902, 1903 and 2004 all fail to POST with four DIMMS set to anything higher than 2400Mhz.

If I use two DIMMS, my rated speed is fine.

On 1802, four DIMMS works fine at rated speed as well.

The problem is in the BIOSs since 1902.

Relevant post: https://rog.asus.com/forum/showthread.php?126889-Z390-F-BIOS-updates-(1902-1903-2004)-all-causing-PO...

Hello, did I install the update (on apex xi) because of the resizable bar? before that, there was version 1704, now the start takes longer, sometimes the system may not start or restart several times (memory and cpu in overclocking, but overclocking is stable in all tests and has been tested for years) tell me if the settings of memory trainers or fast loading can change, how can I achieve a stable start from the first and single pressing of the power button while maintaining my stable overclocking, sometimes a message about f1 appears at all, but rebooting from bios helps to start my computer and it also works stably as before, thanks for resizable bar, but I would like more stability at the start of the system!

I documented my config, reloaded old bios to default, and upgraded to 2004 (primarily for DMA). I reprogrammed my overclock and noticed that I am no longer stable at 4.9 without increasing my voltage (9900k). Before I upgraded, I was stable at a lower voltage. I wish there was a detailed changelog that came with every bios update.

I am sorry that I dont have specifics. I was looking for something else in the forum and realized that I forgot to post my experience with 2004.

Hi there,

looks like I hit a similar issue on my Prime Z390-A with BIOS version 2004.

I have populated all four slots with 4 x 32 GB = 128 GB.
It's a RAM kit that is not on the QVL: Corsair Vengeance LPX 4 x 32 GB - 2666 MHz / PC4-21300 - CL16CMK128GX4M4A2666C16

This kit worked perfectly fine for over a year with BIOS version 1802 with XMP I.

When I upgraded to 2004 it posts, but when I test the RAM with Memtest86 it reports a lot of errors with XMP I.
When I changed it to XMP II, it posts, but Memtest86 still reports some errors (albeit less than with XMP I).

Downgraded back to 1802, everything works fine with XMP I: Post is OK, Memtest86 reports NO errros (after *days* of testing...)

So, it looks like something was messed up in the BIOS with XMP...

Z390-E here, working with 2004. CSM is disabled and Rebar is enabled.