cancel
Showing results for 
Search instead for 
Did you mean: 

1903 BIOS - ROG MAXIMUS XI series

ibushovskiy
Level 7
Hello guys,

Just wanted to update you regarding new BIOS for ROG MAXIMUS XI series

Changes:
- Support WIN 11 installed or upgraded

Download - ROG MAXIMUS XI CODE
Download - ROG MAXIMUS XI HERO (WI-FI)
Download - ROG MAXIMUS XI APEX
Download - ROG MAXIMUS XI FORMULA
Download - ROG MAXIMUS XI EXTREME

Note:
Wanted to highlight that performance decrease has gone with 1903 and my 3DMark results are back to normal. I believe there was an issue with decreased CPU clocks, low voltage and XMP issues with 1901-1902. Same nVidia driver 471.41

1902 BIOS - 7517 Score in Port Royale https://www.3dmark.com/pr/1139088
1903 BIOS - 7999 Score in Port Royale https://www.3dmark.com/pr/1156174
16,636 Views
39 REPLIES 39

Any for the Gene?

1Cenarius
Level 7
I cant download any drivers or bios. the whole download page is gone.

So it seems the ROG MAXIMUS XI GENE Z390 support tab on every ASUS site is gone. Is there any reason for this? Feels like I haven't had this motherboard for too long and it's already EOL for support?

It's gone on every ASUS site too. I wonder why? I actually made another thread about this.

Nate152 wrote:
Hey guys,

Drivers/Bios is now showing for the ROG Maximus XI Gene.

https://rog.asus.com/us/motherboards/rog-maximus/rog-maximus-xi-gene-model/helpdesk_download


Awesome! This is why I exclusively stick with ASUS.

How do 'open a support ticket' with ASUS?

I'm having the same memory issues after updating the BIOS on my Z390-F with x4 matched 8GB sticks of 3000Mhz RAM.

To relay what I've discovered:

* BIOS 1902, 1903 and 2004 all fail to POST when using 4x RAM modules at anything higher than 2400Mhz
* BIOS 1902, 1903 and 2004 will POST and system functions normally if only 2x RAM modules are installed, at their rated speed (3000Mhz)
* BIOS 1802 works flawlessly with 4x RAM modules installed and running at their rated speed (3000Mhz)

Basically, BIOS 1802 is the last stable BIOS for me when using four RAM modules at higher than 2400Mhz. System is rock solid stable on 1802.

If I can open a support ticket too (not sure how), and others, hopefully they'll realise this isn't user-error or a hardware fault and get to addressing the issue properly.

I posted this on another thread but figured I should probably post it here too since I have solved the "getting stuck on white" problem. The problem of 1903 not posting with my new RAM is still an ongoing issue but the white light issue has been fully rectified as I will describe below.

Hey, just want to let everyone know that I've solved part of the problem I was having. I disabled the CSM with 1802 and it started getting stuck on white, but still booting, with the monitor coming on only when it got to the desktop, just like before with the old RAM on 1903. This happened with the new RAM on 1802 for the first time only after disabling the CSM. I realize now that I had disabled the CSM with 1903 on the old RAM as well, trying to get Rebar to work.

I figured out that the problem has to do with how long I wait after initially providing power to the PSU and mobo. With the CSM enabled I can push the front power button on my PC immediately after first supplying power to the board and it boots normally every time, but for some reason when the CSM is disabled I have to wait somewhere between 5-30 seconds before hitting the front power button or it gets stuck on white every time.

Thats why rebooting would sort out the problem, because it had already been supplied with power for much longer than 5-30 seconds.

I've tried this many times now with 1802 and have basically confirmed that if I wait the 5-30 seconds after first supplying power to the board before powering the machine on fully, it boots normally every time with the CSM disabled. If I power on the machine immediately after supplying power to the board without waiting the 5-30 seconds it gets stuck on white every time with the CSM disabled. If the CSM is enabled it will boot normally every time regardless of how quickly I power on after first giving power to the board through the PSU.

That said, this does not explain why 1903 will not post after a fresh install with this new RAM.

I still have not yet tried the latest BIOS myself.

EDIT: It also doesn't explain why I was not able to set the TPM to discrete with 1903. Every time I tried to set it to discrete it would fail to boot and then automatically revert back to firmware. I am still on 1802 and have not tried the latest bios. At this point, I just want to relax and play some games. It sucks that I can't enable rebar with this current bios so I will eventually try the new bios, but for now I'm just enjoying actually using my PC and not having to constantly troubleshoot issues.

BizSAR
Level 9
With this latest BIOS version, all my issues have been solved.
Glad to have helped find the solution, at least for my case. 🙂
BizSAR

2004 posted with the new c14 RAM, although it took many more attempts than it used to after installing a new BIOS(I noticed this with 1903 and the old c16 RAM as well). Never the less, I have the CSM disabled with Rebar properly enabled finally and I'm booting normal every time now so long as I wait the 10-30 seconds after first switching on my surge protector power bar.