cancel
Showing results for 
Search instead for 
Did you mean: 

Won't boot from USB using non-secure mode

JMunsonII
Level 7
Greetings!

I need to install an Other OS, and Secure Boot is not used.

To that end, I have disabled Secure Boot by removing all the keys - so Secure Boot shows as Disabled, and the Key State is Unloaded. OS is set to Other OS.

My boot media, a USB stick, is recognized by the board and I have set that to First Boot.

The BIOS is currently version 0906.

When I attempt to boot to the USB stick, I am returned (quickly) to the BIOS. I do know the USB stick is bootable - I checked it elsewhere (by booting to it). It is as if the Secure Boot mode is stuck "on." On the USB stick is the proper folder/file for this: EFI/BOOT/BOOT64X.EFI.

Setting passwords for the Admin/User did not solve the issue.

I do have a support ticket in to ASUS, but that could be another 36 hours from now before I get a response...

Any thoughts anyone?

Thanks!

Jon
10,011 Views
4 REPLIES 4

dani_arde
Level 7
Hello!
I don't know which kind of OS you are trying to boot to, but I'm able to boot Ubuntu (17.04/16.10) from M.2 SSD or Sata HDD with the following settings in the BIOS (ver. 0906):

CSM
Launch CSM -> Enabled
Boot Device Control -> UEFI & Legacy OPROM
Boot from Network Devices -> Legacy Only
Boot from Storage Devices -> Legacy Only
Boot from PCI-E/PCI Express Devices -> Legacy Only

Secure Boot -> Enabled
OS Type -> Other OS

Hope that helps.

Still no go on the boot to USB stick with those settings... 😞

Greetings!

The OS, I don't think, is really the issue - the USB key I was using is the issue.

I was using a SanDisk Ultra Flair initially, which didn't boot, but switched to a SanDisk Cruzer Glide and that booted no problem.

Jon