cancel
Showing results for 
Search instead for 
Did you mean: 

USB type c and connecting my phone

Jimlad
Level 7
hello all,

i might be missing something, but when i connect my phone via the type c port it comes up it is charging rapidly, but that is it, i cant access it as file storage like i could on my old pc. anyone else had this issue?
Phanteks Enthoo Evolv ATX Satin Black
Asus ROG MAXIMUS IX HERO Z270
Intel I7 6700K Skylake @ 4.5
Corsair Vengeance LPX Black 16GB (2x8GB) DDR4 3200MHz
GeForce GTX 1070 Founders Edition
Samsung SM951 256GB M.2 PCI-e NVMe SSD
Western Digital Caviar Black 3TB
Corsair RMi Series RM850i ATX Power Supply
Corsair Hydro Series H110i
5,541 Views
8 REPLIES 8

FuryA
Level 8
hi Jim welecom the ROG forum
Have try using a different C cabele?
or change ports

Hi,

yes tried a couple of cables, it works if i use a USB type c cable and a Type A convertor on any other the standard USB 3 ports. my issue is just when i plug in to the dedicated usb type c port and straight to the phone it simply charges the device and gives me no storage options. i was keen to know if anyone else had tried this?
Phanteks Enthoo Evolv ATX Satin Black
Asus ROG MAXIMUS IX HERO Z270
Intel I7 6700K Skylake @ 4.5
Corsair Vengeance LPX Black 16GB (2x8GB) DDR4 3200MHz
GeForce GTX 1070 Founders Edition
Samsung SM951 256GB M.2 PCI-e NVMe SSD
Western Digital Caviar Black 3TB
Corsair RMi Series RM850i ATX Power Supply
Corsair Hydro Series H110i

Jimlad wrote:
Hi,

yes tried a couple of cables, it works if i use a USB type c cable and a Type A convertor on any other the standard USB 3 ports. my issue is just when i plug in to the dedicated usb type c port and straight to the phone it simply charges the device and gives me no storage options. i was keen to know if anyone else had tried this?


AS Chino said

it seems like an Android system setting MTP for detection driver
not cables or ports issues. 😆

JustinThyme
Level 13
Is your device listed as being USB type 3.1 compatible? *Not many are. Those that are not require a physical adaptor to make the port backwards compatible but looks like you have figured that one out on your own.*



“Two things are infinite: the universe and human stupidity, I'm not sure about the former” ~ Albert Einstein

Chino
Level 15

it was disabled in the bios 😞

sorry guys i am turkey - all working now
Phanteks Enthoo Evolv ATX Satin Black
Asus ROG MAXIMUS IX HERO Z270
Intel I7 6700K Skylake @ 4.5
Corsair Vengeance LPX Black 16GB (2x8GB) DDR4 3200MHz
GeForce GTX 1070 Founders Edition
Samsung SM951 256GB M.2 PCI-e NVMe SSD
Western Digital Caviar Black 3TB
Corsair RMi Series RM850i ATX Power Supply
Corsair Hydro Series H110i

JustinThyme
Level 13
It's all good brother! *Now others know what to look for.*;)



“Two things are infinite: the universe and human stupidity, I'm not sure about the former” ~ Albert Einstein

hamzayesilmen
Level 7

I solved. I removed battery 30sec and plugged in. Then typec and PD works.