cancel
Showing results for 
Search instead for 
Did you mean: 

USB Over-current and continuous reboot

benkay
Level 7
Hi all,

I left my PC on for a few hours on Saturday (Maximus IX Formula with i7-7700k). At some point whilst I was out of the room, it seems the system turned itself off (not sleep mode or anything like that).

I tried to turn on the computer using case power button, nothing happened. So I flicked off the PSU master-switch and back on again.

This time the PC booted, but only got as far as the opening BIOS "American mega trends" screen, with an error message "keyboard not detected" and "USB Device Over-Current Detected. Will shut down in 15 seconds".

Of course, as always, my keyboard was plugged in as usual.

The system would shut itself down, and if I tried to turn on again, I would simply get the same message.

I disconnected every USB device connected (externally USB keyboard and mouse (both ROG) and internally the NZXT USB Hub with the PSU USB connection and my AIO cooler usb connection attached and the front USB panel connector.

So basically no USB devices at all connected. However, I still got the same message - USB Over-current detected.

I tried flashing the latest BIOS from a USB stick in the BIOS port, this worked OK. BIOS updated but still the same fault message.

Since then, things seem to have deteriorated more. Now the board simply fires up (all lights come on briefly, fans spin), then it has a power-out failure, complete shutdown, then tries to turn on again, shutsdown within 2 seconds....does this in an infinite loop until I kill the PSU power.

Any ideas at all? It seems like maybe a failure of the motherboard to me, but I'm no expert. It' less than 1 year old and not much use.*
12,688 Views
3 REPLIES 3

Korth
Level 14
I'm guessing this fault was triggered by too many USB devices serviced off one USB controller/port. Or by plugging in a non-enumerated USB "decoration" which sucked more power than it should have.

Try a couple boot cycles with absolutely no USB devices connected - not even keyboard, mouse, NZXT hub, PSU - just to see if the mobo will post (as far as "keyboard not detected" error, anyways) and perhaps self-toggle some internal flag back to working state.

Inspect all your USB port pins, there might be bent, broken, or missing pins, there might be debris or residue ... look for anything which might produce an electrical short, maybe blow them out with compressed air or even use an electrical contact cleaner.

Inspect all the USB ports themselves, ensure they're properly affixed onto the PCB with clean solder points, no adjacent components (especially caps and diodes) look "burnt" or damaged or smell funny when the system is powered up, nothing seems loose or wiggly or electrically problematic, no cracked traces, etc.

If you're using a Corsair AX-i PSU then it might be best to keep the CorsairLink USB-to-PSU disconnected until you've resolved this mysterious USB issue.

That's all I've got. Aside from a full mobo RMA or physically desoldering/removing the defective USB port(s). (RMA is probably the better option, if it proves necessary, since the mobo is still under 3-year warranty.)
"All opinions are not equal. Some are a very great deal more robust, sophisticated and well supported in logic and argument than others." - Douglas Adams

[/Korth]

Thanks Korth.

Yeh I've tried numerous reboots with absolutely 0 USB devices connected, all header connections removed from M/B etc.

Visual inspection of the USB ports and board headers doesn't show up any bad connections or bad pins, and the weird thing is the computer shutdown with this fault whilst running normally, I hadn't recently plugged in or disconnected any new USB devices that would draw too much current or damage the ports physically.

*I hadn't added any USB devices than were already connected for just short of a year...and that is only Keyboard, Mouse and the occasional USB stick or external device which is powered by its own power source.

I can't see anything burned, and there was no nasty smell of any description.

Strange thing is now I can't even get to a post screen, the M/b literally shuts itself down within a second of power on (the lights and fans just have enough time to flicker on or spin), then it shuts down for 3-4 seconds, then tries again, in an endless loop.

Because it started off with this weird USB over-current error, I'm thinking its a MB failure of some sort...the PSU seems fine, as in it's giving juice to the MB when it requests it, so I don't think that's at fault.

*

Korth
Level 14
This thread is about the same issue, but unresolved because the @ASUS rep asked for information which was never offered.

https://rog.asus.com/forum/showthread.php?100001-System-instantly-powers-off-when-plugging-in-USB
"All opinions are not equal. Some are a very great deal more robust, sophisticated and well supported in logic and argument than others." - Douglas Adams

[/Korth]