cancel
Showing results for 
Search instead for 
Did you mean: 

Strix z270i bluetooth problem and how I fixed it

Steve94
Level 7
tl;dr: If your bluetooth device just suddenly disappear from your PC (i.e. is no longer in the device manager), to fix:
turn off the computer, turn off the PSU and unplug it, replug and turn on the PSU, turn on the PC. Your bluetooth should be discovered by your PC and usable.


I am a person who prefer wireless peripherals over wired ones. Let it be mice, keyboards or headphones. Wires from the headset rubbing against my shoulder or cluttered desk from mouse and keyboard wires make me nuts sometimes.

About a month or so after I got my new PC with Strix z270i in it, the onboard bluetooth just disappear and no matter how hard I tried to fix it (restarting, reinstalling drivers or even reinstalling Windows) nothing works. And when I about to RMA the board, the bluetooth device is back running a again. (I remember a power outage before that.)

And then it happened again... My computer can't find the bluetooth device on the board. This time I quickly remember that power outage that some how fixed my bluetooth. Then I shut down the PC. Turn off the PSU. Unplug and replug it. And turn it back on. BOOM. FIXED!!1! The bluetooth device is discoverable again!

I registered to this forum just to put this here and hope it helps other people who has the same problem. From reviews on Newegg and Amazon, seems like several people have been having the same problem.
29,618 Views
11 REPLIES 11

kentieu
Level 7
I have exactly same issue with my maximus ix code. Don't know if it's because the BIOS or hardware. If it's BIOS I don't mind to wait Asus release the corrections, *but if it's because the hardware i have to return it, don't want to pay over $300 for the mobo that come with error

Wow, I had this issue on my z270G and your fix worked! I was seriously pulling my hair out trying to figure out this issue. Thanks!

LemonCitron
Level 7
Have the same problem on my Asus z270 Maximus IV Code. Bluetooth just disappears and nothing brings it back until I pull the power. Even that doesn’t bring it back every time. Has anyone contacted Asus to let them know about this issue?

My Z270Itx mobo randomly loses the Bluetooth also.... I open Device manager and it says unrecognized USB device ???

I have tried the shutdown method , doesn't work for me , so I install the drivers again and it worked... This happens 3 times over a montho keeps losing the Bluetooth and its strange because when I uninstall the unrecognized usb device and scan my pc , doesn't automaticly find the driver , I have to always set up Bluetooth manually from ASUS site

You are not the individual case, I searched online and found many different cases from different regions/Languages with exactly the same Problem, Bluetooth disappeared for no reasons and nothing works on recovering until cutting off the power from the Motherboard, e.g: Unplug the Main Power for some time until the LEDs on motherboard goes off then Power it backup again, The problem will be temporary fixed, or Clear CMOS will do the same trick. Some Z270i Owners also reported other Bluetooth related issues such as Bluetooth devices can not be paired etc which can be resolved using the CUT-Power trick. See References Linked Below:

https://rog.asus.com/forum/showthread.php?93816-Strix-z270i-bluetooth-problem-and-how-I-fixed-it

https://linustechtips.com/main/topic/837764-bluetooth-not-working-asus-strix-z270i-windows-10/

http://www.hyr5.com/f4/t25319

https://rog.asus.com/forum/showthread.php?92000-Bluetooth-Wifi-on-Strix-Z270E-not-working-at-all

https://linustechtips.com/main/topic/778894-asus-z270i-bluetooth-gone/

https://www.tonymacx86.com/threads/success-twsps-build-asus-z270i-strix-i7-7700k-hd-630-4k-m-2-alc12...

https://www.reddit.com/r/ASUS/comments/634tcx/asus_z270e_bluetooth_not_working/

https://www.reddit.com/r/buildapc/comments/6bv9h2/z270e_motherboard_bluetooth_suddenly_stopped/

And Maybe this:

https://rog.asus.com/forum/showthread.php?87740-Bluetooth-gone-completely-after-PC-refresh-Not-in-de...

Most of the cases were on ASUS Z270i Users, but also reported by other ASUS Z270 (Z270E etc.) Motherboard Users, So ASUS, Please fix your stuffs.

man, you rock!

the same issue with my Z270i and power trick helped.

Just came across this thread. Dont think I had the disappearing Bluetooth devices issue but I could never get my high-end Bluetooth speaker to pair with the Z270G inbuilt bluetooth. I ended up buying a cheap ASUS bluetooth USB dongle and it did the trick and has been stable for 6 months.

I use Windows 10 on an ASUS 270E
At end I have found a solution for my not stable Bluetooth devices

The problem is related to the very old version of the Artheros Bluetooth driver provided by ASUS
I don't understand why ASUS don't react

Try Snappy Driver Installer
http://www.snappy-driver-installer.org/

This (portable) product will retreive and install for you the last version of the Artheros Bluetooth driver
And it works !!

I am here to confirm that it is almost 2020 and it is still happening. I have asus x570 e-gaming and if I do not turn off the power after turning off the computer, I will not detect the bluetooth module in Windows.

Does anyone know any permanent solution?