Showing results for 
Search instead for 
Did you mean: 

STRIX Z270G - (A7) ME Firmware Downgrade - Request MeSpiLock Failed

Level 7
Motherboard model: STRIX Z270G Gaming

UEFI Version: 1301
(ME Version:

CPU: Intel Core i7-7700K KabyLake

Memory kit part number (s) and amount in GB: F4-3200C16Q-32GTZR 32GB

GPU: EVGA GeForce GTX 970

SSD/HDDs/Optical drives: Samsung 840 EVO 1TB, WDC Blue 4TB

PSU: Corsair SF600

USB Devices (model/version number):

Razer Blackwidow Chroma Silent (v1.0) keyboard
Logitech G9x Mouse
Astro A40 DAC


PC CASE: CaseLabs Bullet B4

Operating system: Windows 10 64 bit Pro Microsoft Activated yes/no? YES

Drivers Installed (include version info):

Intel(R) Management Engine Interface V1914.12.0.1256
Intel Chipset Device Software V10.1.18019.8144
Realtek Audio Driver V6.0.1.6699
Intel LAN Driver V12.17.8.7

Any third Party temp/voltage software installed: None

System Overclocked (provide details)?: Yes.

Memory at XMP timings.


Every few cold boots, I see the "(A7) ME Firmware Downgrade - Request MeSpiLock Failed" issue.

About 6 months ago I had updated my BIOS to 1301 from 906 (using default settings and updating the BIOS in order till latest) as well as some other ASUS drivers, all retrieved from the official ASUS support page for this motherboard, and that's when the issues started. Since then I've been getting different BSOD's in Windows and the Firmware Downgrade issue. The reason for the BIOS update was because 906 didn't have proper XMP support for my RAM.

I tried the solutions of swapping from Secure Boot to Legacy and back, clearing the CMOS, updating the MEI, reverting back to previous BIOS, checking the system drive and RAM for inconsistencies, but nothing has worked so far. The system will appear stable for some time and then start having issues again out of the blue.

I've reinstalled Windows 10 thinking it may be some issue with updating the BIOS and Windows 10 not liking it, but the same issues persist.

I would appreciate any ideas to solve this.