cancel
Showing results for 
Search instead for 
Did you mean: 

PC doesn't power on when DP cable is connected to GPU

Lamarao
Level 7
Hey there,

I've been struggling with an issue regarding my latest build which as puzzled me and I can't find an answer anywhere online.

Basically my build has the following components:

- MOBO: Asus Strix Z270i Gaming (new on my build)
- CPU: Intel i7 7700K (new on my build)
- RAM: Kingston KVR21N15D8K2/32 2 x 16GB (had before)
- GPU: Asus Strix 1080 (had before)
- M.2 SSD: Samsung 950 Pro 512GB (had before)
- PSU: Corsair SF600 600W (had before)

The issue is: If I have the display port cable connected to the GPU I can't power on the computer, all the RGB led's on the mobo and whatnot are shining, but pushing the power button does nothing at all. Then, if I disconnnect the display port cable from the GPU all of a sudden I'm able to turn on the computer and afterwards I connect the cable to the GPU and I'm able to get an image on the monitor, post and boot into windows.

I don't think the problem is with the GPU because I had it before and it worked flawlessly with another motherboard and CPU. Also, initially the mobo wasn't recognizing all 32GB of RAM, I had to update to the latest bios in order to do so. Additionally, the status led on the board (the one close do the pcie slot) is constantly red.

Any help is really appreciated, as I didn't really wanna have to the store where I bought the motherboard.

Thanks!!
2,785 Views
4 REPLIES 4

NemesisChild
Level 12
Welcome to the forum!

Switch out DP cables if you can or try a DVI connection instead to test.

I would also remove the 1080 and test with the onboard iGPU.
Intel i9 10850K@ 5.3GHz
ASUS ROG Strix Z490-E
Corsair H115i Pro XT
G.Skill TridentZ@ 3600MHz CL14 2x16GB
EVGA RTX 3090 Ti FWT3 Ultra
OS: WD Black SN850 1TB NVMe M.2
Storage: WD Blue SN550 2TB NVMe M.2
EVGA SuperNova 1200 P2
ASUS ROG Strix Helios GX601

Chino
Level 15

Retired
Not applicable
I'm having a similar problem

i have maximus ix hero my monitor Samsung C24FG70

when i use DP connection the monitor shows no signal and doesn't work and i can't enter the Bios

i tried everything
i tried hit Del no bios
i install new bios 0906
i install bios 0801
i change cable
i change port DP in my card asus strix gtx 1080
i change to port DP in my M.B.
***no signal in post boot**

Nate152
Moderator