cancel
Showing results for 
Search instead for 
Did you mean: 

Monoblock not making contact with CPU.

BlueScreen
Level 7
The motherboard is a Maximus IX Extreme.

I got zero help from ASUS support on this when I called the North America line. The first response after explaining the problem was that I should seek out local technician for support. I asked to speak to the supervisor and the tech said all his supervisors were unavailable. I asked for an email so that I could respond with the photos below to be certain that there was no misunderstanding of my problem. The tech said he couldn't create a ticket or RMA because their ticketing system was offline. So here I am.

The system has been on air for 2 weeks. I am attempting to install the monoblock. I applied thermal grease on the CPU and put the monoblock in place. As you can see the monoblock is not making contact with the CPU because the thermal grease did not spread out. The photos below were taken after I removed the monoblock from the motherboard to validate proper contact with the CPU. There are 2 screw holes nearest the IO Shield that have to go into the holes in the motherboard so that the monoblock can be properly seated. I confirmed that it was indeed fully seated.

64676

64677

I need to know if there is anything that can be done to remedy this problem. Perhaps is there something that I missed?

I don't expect everything to go off without a hitch. I am a network architect by trade. I get paid to solve problems and deliver solutions. But I paid $650 for a motherboard that is supposed to be topshelf and when I do encounter a problem I get totally indifferent incompetence from ASUS support. The lack of contact between CPU and Monoblock is a problem that will get fixed one way or another, whether I go with a competitors product, get an RMA, or use a different waterblock, I got spare waterblocks, I can deal with that. But my dealings with ASUS support so far on this issue has been totally unacceptable.
137 Views
11 REPLIES 11

Chino
Level 15
Try not to overtighten the screws. Uneven pressure can prevent the CPU from making full contact with the socket.

BlueScreen
Level 7
Just wanted to report back that

#1. ASUS issued an RMA for my motherboard.

#2. I didn't have to use the RMA. Before I was going to go the trouble of RMA, I went out and bought a 7th gen i3 processor. Popped it in and it booted right up.

My CPU had died. I had gotten it from Silicon Lottery and they replaced it under warranty. It does the advertised 5.2ghz at 1.4v and 75c. I backed off a bit though for the sweet spot. I am running it at 5.0ghz, 1.25v and 60c. It is delided.