cancel
Showing results for 
Search instead for 
Did you mean: 

I need some help, clear CMOS button always Lit?

mr_palm
Level 7
Hello,

I recently got the Maximus IX hero, and was messing around in the UEFI/BIOS. I accidentally overclocked my ram too high and the computer wouldnt even post, so I decided to clear the CMOS with the button on the I/O panel on the back of the motherboard. Prior to pressing it there was no light, however after I pressed it a green light came on, highlighting the button, and when I started my computer, the CMOS was cleared, however the green light is still on. Is it normal for it stay on after being pressed the first time, or should I be worried?

Thanks
9,924 Views
6 REPLIES 6

Arne_Saknussemm
Level 40
The clear CMOS button has always been lit on the boards I have had...

🙂

schoolofmonkey
Level 7
Mine's lit too from new.

Mine has also always been lit (old motherboard though); if you are not experiencing any issues, then I would not worry about it.

Chino
Level 15
mr_palm wrote:
Is it normal for it stay on after being pressed the first time, or should I be worried?

Yes, it is. It remains lit always.

Thanks everyone for the replies, for some reason I thought it wasn't on before, I didn't remember it being lit up. I appreciate the help

userz
Level 7

7 years later, had the same exact concern on the x670e hero. It wasn't lit at the first couple boots, had some problems, pressed the cmos button to reset it, did not work (only got red led after that), so I thought it was stuck in trying to reset cmos or something. Instead of the cmos the bios button was lit on for some reason.