Showing results for 
Search instead for 
Did you mean: 

How to setup in Legacy Boot Mode?

Level 7
I've been having constant problems with my Sound BlasterX AE-5 soundcard not being consistently recognized at boot. It seems it is extremely similar to the issue that the older Sound Blaster Z cards had several years ago where they were not recognized on many, but not all, UEFI systems. The fix was to disable UEFI and boot in Legacy mode with CSM enabled. It sounds as if I'm going to need to delve into this myself, if I want to fix my sound card issues and not have to restart my computer four times every single time I boot from a shut-down state.

My main boot drive is a Samsung 850 EVO Series 500GB SSD, that is currently setup as GPT. I believe I need to convert it to MBR, then set my Maximus IX Hero up in Legacy Mode and reinstall Windows 10. I'm not sure, but I think Secure Boot has to be turned off.

Is anyone willing to point me to any online resources that may help me in this endeavor?


Level 15

Level 14
Which slot do you have the sound card in?
Have you changed any bios settings?

No problem with same sound card on my X Apex, also had it on my X Hero without issue , must be something else besides motherboard or OS IMO

Yeah, done all that. Been there, done that. Tried the card in every available slot, same issue. Changed BIOS settings around at Creative's request, same problem. Tried the card in my wife's computer, no problems whatsoever, works perfectly. Finally RMA'd my motherboard to ASUS. They had it for the past week and could find no issue at all. Ran full diagnostics on it and couldn't reproduce the problem. Of course, they wouldn't be able to reproduce it unless they had the same exact sound card, which I doubt they did, but I'm sure they did a decent job of going over the card. My Sound BlasterX AE-5 uses the same core, or maybe a slightly modified core as the Sound Blaster Z. When I really started researching the issue, I found tons of references to an issue with the Sound Baster Z based cards that sounded exactly like the issues I'm having. No sound after booting up, the card is often incorrectly recognized as a Sound Blaster Recon3D, requires multiple restarts to get sound back. In almost every instance, the users were told there was an issue, some sort of incompatibility, with their motherboard's UEFI implementation. If they changed from UEFI to Legacy BIOS, the problems went away and they never experienced them again. It makes sense now to me why the Creative Techs kept suggesting that I try booting into Legacy mode. They know there's been an issue for a while now, and there obviously still is with some motherboards. As recently as two weeks ago, another user on the Creative Labs forums asked for help with the exact same issue that I'm having and their motherboard is an Asus ROG STRIX Z270F.

Anyway, at this point, without actually trying anything yet, I'm all but convinced that this will take care of my issue.

What confuses me is why the sound card works perfectly on my wife's GIGABYTE G1 Gaming GA-H170-Gaming 3 based system. Her board is UEFI based as well, but the AE-5 works perfectly with her system. What also astounds me is that Creative has known about this problem, and that it's been present through at least two, possibly three generations of their sound cards, and they still haven't found a way to correct it. I just read today that Intel based boards will completely do away with Legacy BIOS and will be solely UEFI-based by 2020. What the heck are Creative owners going to do then? Everyone will have to restart their computers four times at boot to get their soundcards to work, just like I do now.

Anyway, I have my four restart fix down and I know it works, so I'm not in a huge rush, but I plan to redo my system within a week or two in Legacy mode and I'll post back what the results were.

Level 14
Well that's a just shame, I have learned to only purchase from a retailer with a 30 day return policy, if it has any issue it goes back.

I wish you luck and hope it all works out for you