Showing results for 
Search instead for 
Did you mean: 

Corsair Link - Maximus IX code/Hero/Formula

Level 7
I have*the*Maximus ix Code & the Corsair H110i GT. I can't*get Corsair Link to show my case fans (they are in cha1, cha2, cha3). I've tried a few things in the BIOS but so far nothing*has worked: 1. Turning off Qfan control - nothing 2. Setting Qfan control to PWM - nothing 3. Setting all fans to DC Mode - Nothing.*

H110i GT*Fan Headers - I have the pump connected to*USB2,*Pump is connected to the CPU Fan header and the two radiator fans are connected to the pump via the supplied Y splitter.

I had it all working fine witn my previous board (Maximus vii hero). There must be something I'm missing here? Do I have to make a change in BIOS then reinstall Link?

Any help? Thanks all.

Level 12
A lot Corsair fans don't follow Intel specifications so they're known to cause issues with a lot of other hardware like fan controllers or motherboards.

I also owned quite a bit of Corsair fans/products and they pretty much force you to have to use their software to properly control their fans. I ended up junking all my Corsair fans and bought some Noctua fans and issue was resolved.

That's pretty strange that you already disabled fan control in BIOS and it's still not detecting it. Try updating the BIOS?

Level 14
I didn't know that Corsair Link could control or monitor fans other than what are connected directly to the pump
I never use the control software myself, I prefer to let the bios control all my fans, I don't connect the USB cable or install Link
I connect the pump to the pump header and rad fans to CPU and CPU_OP headers, I leave the pump control disabled so the pump runs full speed and rad fans I set to Turbo mode in bios, I set all case fans to silent mode and let ASUS bios control all my fans, it's just to easy and no possibility of software conflicts
You can also manually control all fans in the bios using temperature and percentage of fan speed, this also works very well
I use one program to monitor everything AIDA64 and that's it.
I guess I have memories of software conflicts from prior use, Corsair Link, mouse and keyboard software, etc. that caused conflicts that I see no need to install anything not needed

Ill*try setting it up the way you have it. If I set the rad fans to 100% can I control them at all outside of the bios in the os? Isnt that a bit loud? Thanks for the reply man!

Level 14
ASUS fan expert a part of AIsuite can control the fans while in the OS, there are a couple ways to control in bios, settings of silent, normal, turbo, or manual control using temperature and fan rpm percentages,, all will raise and lower fan speed according to temperature, you can find this info in the manual

Think I’ve a similar problem.

Today I installed the Corsair H115i. First boot was making the fans running 100%. The Corsair Link wasn’t detecting the H115i which was connected at the internal usb 8 pins. Changing the usb 8-pins to a normal usb cable (using the usb port at the back panel) worked, and the Corsair Link detected my H115i. But still both fans running at 100%. Nothing changed. I did tried every possible profile. There was/is simply not any communication between the H115i and the fan’s.

My solution was the connecting both fan’s (with a 4-pins splitter) to the CPU 4-pin on the board, and manage them with the AI Suite 3. Not the best option, because this software package gives a lot of Blue screen of deaths (IOmap64 etc.)

Level 13
You can set the fan profile directly from UEFI. The BSODs with fan xpert are liekly due to conflicts with Corsair Link. Too many things polling the superIO at the same time I suspect.

Raja@ASUS wrote:
You can set the fan profile directly from UEFI. The BSODs with fan xpert are liekly due to conflicts with Corsair Link. Too many things polling the superIO at the same time I suspect.

The BSOD was indeed more after when I installed the Corsair Link, but before that it was giving the BSOD as well. I've installed Windows 10 3 times, but unfortunately the BSOD stays. Now, it's just there from time to time. Mostly with a cold boot.
Also problems with the Asus Aura. After install everyting looks fine, but then suddenly (after installing other software) it constantly consumes 13% of my CPU.

I think Asus have to go back the drawing board. The IOmap64 BSOD was already reported in 2012.:eek: Copy/past old code?

Level 13
Seems to be unique to you as none of this happens to me 😉

Try to disable the CPU FAN monitoring and the Q-FAN options in BIOS for the CPU.

Then it should be compatible with the Corsair application.