Showing results for 
Search instead for 
Did you mean: 

BSOD on ASUS ROG MAXIMUS IX FORMULA (driver/software issue)

Level 7
Hi everyone!

I have relatively new PC (bought in February 2017). Spec are:

Operating system: Windows 10 Home (Build 15063), 64-bit
Monitor Name: Generic PnP Monitor
Monitor Model: ASUS VX239
CPU: Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz (8 CPUs), ~4.2GHz (not overlocked)
Memory: 32768MB RAM Corsair Vengeance LPX (4x8Gb)
Hard disk 1: 240Gb SSD Corsair Force LS Series
Hard disk 2: 4Tb SATA-III HGST (Hitachi) Ultrastar 7K6000
Graphics: NVIDIA GeForce GTX 1070
Sound card: Realtek Digital Output (Realtek High Definition Audio)
Power Supply: 750W Corsair RM750i

External devices:
USB3 Hub (with additional power supply)
WD My Passpoet External drives 2Tb x 4

Since February till August my PC run without single issue - no errors, no BSOD. Situation changed in August when first BSOD occured. Code of BSOD was 0x7f (8). I browsed internet for a bit and found out that the problem could be caused both by hardware and driver issues. I've ran memtest - no memory errors. So I desided to research further and look closely in BSOD dumps. It seems that it was bluetooth driver (btfilter.sys) that causing problem.

BugCheck 7F, {8, fffff8030ba22e70, fffff8030ba0afc0, fffff80308f08657}

Probably caused by : btfilter.sys ( btfilter+1467a

0: kd> knL
*** Stack trace for last set context - .thread/.cxr resets it
# Child-SP RetAddr Call Site
00 fffff803`0ba0afc0 fffff803`08d9a831 nt!ExAllocatePoolWithTag+0x2b7 << We crash here!
01 fffff803`0ba0b0b0 fffff801`55a7c22e nt!IoSetCompletionRoutineEx+0x51
02 fffff803`0ba0b0f0 fffff801`55a9e56d Wdf01000!FxIrp::SetCompletionRoutineEx+0x36
03 (Inline Function) --------`-------- Wdf01000!FxDevice::_AcquireOptinRemoveLock+0x47ad9
04 fffff803`0ba0b140 fffff801`55ba1262 Wdf01000!FxDevice::DispatchWithLock+0x47b2d
05 fffff803`0ba0b230 fffff801`5c27467a ACPI!ACPIDispatchIrp+0x1c2
06 fffff803`0ba0b2b0 00000000`00000007 btfilter+0x1467a << Our faulty driver
07 fffff803`0ba0b2b8 ffff9886`7a653f68 0x7
08 fffff803`0ba0b2c0 ffff9886`7d58ade0 0xffff9886`7a653f68
09 fffff803`0ba0b2c8 ffff9886`7a586180 0xffff9886`7d58ade0
0a fffff803`0ba0b2d0 ffff9886`00000020 0xffff9886`7a586180
0b fffff803`0ba0b2d8 00000000`00000000 0xffff9886`00000020

I was a bit surprised, since I never used Bluetooth on my Desktop. I asked about that issue on few software forums - I was adwised to update Bluetooth driver and watch the results. I updated driver to ver. .

For one month situation was fine, untill I get another BSOD on September 4th (with same error code and same file causing problem). I'm not quite sure about my further actions - should I delete or disable Bluetooth driver or take any measures? Does anybody faced same problems?

1. Dump file August 8 (google drive)
2. Dump file September 4 (google drive)
3. DxDiag (google drive)


Sorry for harsh English. It isn't my first language.

Hi kvizerad

If you;re not using bluetooth you can disable it in the bios, Advanced tab, Onboard Device Configuration.

Hi Nate152!

Yes, I thought about that too, but still... I'd like to understand mechanism of that issue and find a solution that doesnt involve disconnection of any integrated devices. Also, maybe I'm not the only person who had that problem.

I'd like to keep that for extreme measures.:)

Personally I don't use bluetooth and I disable it. You could disable it and see if the blue screen goes away, if you still get the blue screen then you'll know the problem is elsewhere.

Some things to try:

Run CCleaner to clean the registry.
Scan for viruses.
Run the system file checker, in command prompt type in sfc /scannow and hit enter.
Update the bios and all drivers.
Last case scenario, reinstall windows.

Well, here what I did recently:

1. Install CCleaner and cleaned the registry... didn't help
2. Check for viruses/malvare - I got updated Kaspersky on all the time, and I don't visit any suspicious sites, so that probly not the case.
3. I didn't changed CMOS setting since I bought the PC - it is all on defaults.

...get third BSOD - 09/17/2017

4.After third BSOD that occured today, I decieded to update BIOS - now it is v.1009 (that is quite scary process when you flash it on your own for first time in life:D)

Will look forward for system reaction next few days.

All right sounds good !

Way to go on flashing the bios for the first time, ASUS made it rather easy too huh. 🙂

I'm using bios 1009 myself and all is running well although I'm not using bluetooth, fingers crossed the bios update fixed you.

Give us an update anytime.

Well, it seems it weren't BIOS issues causing that problem - I get another two BSOD's (10.01.2017 and 10.04.2017). Sourse - bluetooth again.

I checked windows logs also, here how it goes:

1. 21:30 - PC on
2. 03:33 - Get first warning: "A command sent to the adapter has timed out. The adapter did not respond"
3. 06:53 - Get last warning
4. 06:56 - Get BSOD

Could it be hardware issue with USB adapter or Bluetooth device itself?

Did anybody face same problem or I'm the 'lucky' one? It disturbs me much - what if that IS issue with USB-adapter and someday it'll result in short circuit or something like that?

l Would do what what @Nate152 recommended and disable the bluetooth at the bios level if you are not using it....but that would bother the hell out of me 😉 If you do require bluetooth can you verify that the driver version in Device manager as

Driver: Qualcomm Atheros QCA1x4A Bluetooth 4.1
Driver Date 4/18/2017

and verify that the driver files in the driver details are the following.


From there I would then recommend using Windows Driver Verifier on the driver that is causing the issue and review the dumps and send the results to ASUS Tech support and let them analyze it and hopefully they can identify whether you have a driver issue or hardware issue and RMA.