Z270
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Intel optane with Samsung 960 pro

Hey guysSeems only natural to point out this question once the tech is available next month.Intel optane m.2 is releasing April 24 tho with 16 and 32gb. They claim that this optane m.2 will increase your systems storage performance by 30% (that's spi...

qUAanA by Level 10
  • 5241 Views
  • 2 replies
  • 0 kudos

W_Pump Header questions

I just migrated from another maker's motherboard to a Maximus IX Formula, and am starting to try out water cooling. Not all of my parts are here yet, but I did set up a GPU-only loop, using an EKWB EK-XRES 100 SPC-60 pump, which only uses a PWM conn...

fjc by Level 7
  • 4994 Views
  • 1 replies
  • 0 kudos

7700k + MAXIMUS IX HERO overheat?

Hi Guys,I am not really new to this forum but it is (i think) the first time I have some real troubles. A few weeks ago I bought my new System (specs see below) and noticed a problem while using the Intel HD graphic. (still waiting for the 1080 TI St...

R3aper by Level 7
  • 4131 Views
  • 3 replies
  • 0 kudos

Notice: RST Beta (Intel Optane)

Hello ROGer, I would like to share my personal finding about the RST Beta (Intel RST driver 15.5.0.1047).If you happened to updated this version and experienced shutdown / sleep / hibernate problems, please revert back to RST stable version. Experie...

Maximus IX Apex XMP 4266MHz Issue.

Hello there.Just built a new system with the Z270 Apex motherboard paired with a 7700K and I'm trying to make my G.Skill TridentZ 4266MHz ram to work but the system just won't boot at that frequency. What I did was enabled the XMP profile and dialed ...

Vangry by Level 7
  • 20750 Views
  • 33 replies
  • 0 kudos

ASUS ROG Formula IX leds going rainbow when in hibernation

So i have in BIOS selected that the led are to be turned OFF when in sleep/Hibernation mode but the led keeps being on and going rainbow on the MB only the GPU is off and the sli bridge. when the system is on it is working just fine but it's like the...

Teletha by Level 9
  • 2033 Views
  • 4 replies
  • 0 kudos

z270H won't post with XMP 3200 memory setting

I need some advice of what could be going on. Hardware list:STRIX Z270H GAMING BIOS 0906I7-7700k CPUG.SKILL Ripjaws V Series 16GB (2 x 8GB) DDR4 3200 (PC4 25600) Model F4-3200C16D-16GVKBWhen I boot up with the BIOS at the default settings everything...

zorin1 by Level 7
  • 13031 Views
  • 11 replies
  • 0 kudos

G.Skill Trident Z RGB - LEDs not controlable on Formula IX

On my Formula IX I installed G.skill Trident Z RGB (F4-3200C16D-16GTZR). Unfortunately, the memory is not recognized by Asus AURA or the G.skill tool.The tool aborts the boot process with the message "No Trident Z RGB modules installed". I have alrea...

proph by Level 7
  • 2279 Views
  • 2 replies
  • 0 kudos