Z270
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

MIXH shutdown issue

I don't know if this is a problem specific to my build or not but I'd say 20-30% of the time my system doesn't shut down. I'm running 7700k no-HT @5.1g no other setting's changed. I'm also running the second to last BIOS so if it's a BIOS issue mayb...

maximus ix formula boot order

Hi Guys, just finished an upgrade with maximus ix formula, i7-7700k, 16gb g-skill ddr4 and Samsung 960 m.2 drive, started the system with the old Samsung 840 evo ssd with no problems, used Samsung data migration to clone the 840 over to the 960 m.2 w...

Maximus IX Hero Intel ME problem

Hello, everyone!There is a problem with my with Maximus IX Hero mobo.After POST and BIOS logo I have an error message: (A7) ME FW Downgrade - Request MeSpiLock failed.In Device Manager there is STATUS_DEVICE_POWER_FAILURE near Intel Management Engine...

vrnsk by Level 8
  • 7168 Views
  • 13 replies
  • 40 kudos

Samsung 960 EVO m.2 and Maximus 9 Apex

Hi,I am using 256GB 960 evo m.2 with maximus 9 apex board. Currently Samsung magician shows the interface as PCIe Gen3 x2. Is this normal like instead of x4?CPU is i7 7700k. Using nvidia 660ti gpu and the 4 sata ports are used. I have updated the nvm...

Maximus IX Code not waking up

Just installed a Code with i7 7700K. Everything is working fine expect that it will not wake up the monitors coming out of sleep mode.. I have spent a lot of time on the net trying different things but no joy .. Looking for a solution..

maximus ix formula usb header wrong!

My maxiums formula ix z270 have usb header 1314 wrong.. pins are in wrong way!!! nobody have same issue? **** ***** instead of*********

Maximus IX Extreme Cooling

I have a ROG Extreme IX motherboard on order and I wish to install a Corsair H115i AIO cooler. There does not seem to be a CPU fan header on the motherboard. I am wondering how to make the H115i cable connections to this motherboard?

PC doesn't power on when DP cable is connected to GPU

Hey there,I've been struggling with an issue regarding my latest build which as puzzled me and I can't find an answer anywhere online.Basically my build has the following components:- MOBO: Asus Strix Z270i Gaming (new on my build)- CPU: Intel i7 770...

Lamarao by Level 7
  • 2756 Views
  • 4 replies
  • 0 kudos