cancel
Showing results for 
Search instead for 
Did you mean: 

Z170 Ranger issues with GTX 680/PCIE slot

Valdas
Level 7
Hi All,
Recently I've received my Z170 Ranger motherboard with new processor and ram. Once everything was assembled and software installed I've noticed that when GPU is under load the frame rate starts dropping rapidly until it reaches around ~20 FPS. At that point systems becomes unstable which eventually ends with either system freeze or NVidia driver crash.
I've started debugging the issue and this is what I've already tried without any noticeable changes:

- Tried both 362.00 and 364.72 NVidia drivers.
- Updated motherboard bios to latest version.
- Tried disabling/enabling XMP.
- Tried manually specify PCIE generation (Auto/Gen3/Gen2).
- Re-flashed GPU bios.
- Cleaning GPU cooler. Adding fresh thermal paste.

Things that somewhat improved the situation:
- Moving graphics card from PCIEx16 to PCIEx8 seems to help with system stability, but performance drops to a "slide show" during gaming situations that originally had no such issues.
- Forcing GPU cooler to run at maximum RPM. It now takes a bit longer for the system to reach the point at which it freezes.

After these observations I assumed that my GPU is either damaged or overheating, but both GPUZ and Afterburner is showing GPU temperature under 70 degrees under load, and it seems to be working fine when I install it to my friends PC.
Another interesting observation is when I install AMD 280X. With this card system seems to be stable even under GPU load, though there is a significant FPS drop when I run a 1080p@60 youtube video on my second monitor.

Is there something else I could try, or is it already safe to assume that this is a faulty motherboard?

For anyone else wondering about OS/PSU, I'm running Windows 10 Pro 64bit and using Corsair RM650i PSU.
3,079 Views
2 REPLIES 2

Nate152
Moderator
Hi Valdas

Welcome to the ROG forum.

You could try the NVidia hotfix to see if it helps anything, after the license agreement click custom/advanced install, install only the graphics driver and PhysX driver then check the only box that says performr a clean installation.

I don't know if this will fix you but it's worth a try.

http://nvidia.custhelp.com/app/answers/detail/a_id/4086/~/geforce-hot-fix-driver-version-364.96

This hotfix is regarding Doom beta, but I'll try. You'll never know with these kind of things. On the other hand my older rig running same card was fine with 362.00 drivers.