Showing results for 
Search instead for 
Did you mean: 

Win XP Pro on Maximus VIII Formula question

Level 9
Just received my lovely formula mobo. Currently running OpenSuSe on it for test purposes. So far so good. Plan to install Win10 Pro once I get the bitlocker issues figured out.

As a standard practice I usually pop on a HDD with Win XP Pro for test purposes and this almost always works (of course the OS needs to be re-verified)....

Tried to boot with a known good XP Pro HDD and got as far as the failed boot screen. None of the choices worked including safe mode, no networking.

This is my first ROG build and my first syklake build. Is there something about this new stuff that would prevent XP Pro from running?

I have several legacy XP machines that I still use in "production" mode. I was planning on upgrading the hardware to ROG to speed them up some but continue to run XP Pro for a while longer.

I realize that XP is well past end of life but if I can migrate these old XP HDDs to new ROG mobos that would be great.

My "system" is currently in a very bare, breadboard stage. G4400 CPU, 16Gb g.skill 3200 RAM, BIOS:2202

Advice, tips, comments will be most appreciated.

Hi Jones0610

I doubt you'll get any responses to this as no one here is using windows XP, I would use windows 10 from the start to ensure compatibility.

I appreciate the response and I'd certainly agree with your comment. I have no plans to run XP on this mobo other than for testing purposes. However, since there is no ability to migrate XP to Win10 I plan to keep running XP on my "production" machies for as long as possible. If I can upgrade the hardware to breathe a little new life into those old boxes I'd love to do so. Upgrading to ROG mobos will make the inevitable move to Win10 a lo less painless.

My question is really about whether there is something about ROG/skylake/Z170 that *PREVENTS* XP Pro from running. I was quite surprised when it didn't just boot right up. Could be just a boot setting in BIOS.... haven't really looked into it yet.

Since I have this thread open, wondering if anyone is running Linux.... specifically OpenSuSe. Perhaps in Hyper-V. So far it seems to be running fine on my mobo although I am unable to get the ASUS built-in wifi to work. Currently using a garden variety USB wireless adapter.

I have a ROG G750 laptop that I love. And so far I've been very impressed with the Formula mobo. I'm not really a fan of Win10..... doesn't take much to break it and I've already had to rebuild the laptop twice. I built the XP machine I am typing this on ten years ago and I have had almost zero problems with it.

Hoping I can get some knowledgable thoughts on this. As I said, I'm obviously not buying high end ROG hardware to run a legacy OS on, but.... if I can upgrade my current half dozen XP Pro systems to new hw it will make the inevitable upgrade to W10 a lot easier. This is the first time I have ever installed an XP HDD in a new mobo and had problems. Wondering if there is something about the ROG BIOS/skylake/Z170 chipset that would prevent this from working.

My M8F is running OpenSuse just fine at the default settings. Will be installing W10 pro as soon as I can get a response on my bitlocker issue.

With a known good XP Pro HDD installed, it goes through the BIOS, windows starts and then goes back to the ROG logo screen. Tried setting secure boot to "other os".... no difference.

For fun, tried booting from the XP Pro install CD and after loading most/all of the software it blue screens.

I could really use some expert advice here. If the M8 mobos won't support XP that's going to put a real crimp in my upgrade plans.

Many thanks in advance.

I'll check around and see if I can find anything on windows XP being compatible with the skylake z170 chipset.

I'd be much obliged Nate!

In your travels, if you could inquire about M8F native support for Win10 bitlocker, that would be a great help as well. Support confirmed there is no provision for a TPM on this mobo so I'm wondering if W10 os encryption is supported. Assuming it is but there is zero documentation on this.

Win10 Pro is an additional $100 over the home edition and the only relevant extra you get is bitlocker.... a lot of extra dough if my ROG mobo won't support it.

Well I did come across this and it does seem that windows XP will work with the skylake platform.

I'm not sure about the bitlocker as I don't use that, i'll have to check around on that too. 🙂

Interesting article. XP was/is certainly Microsoft's best OS. W10 is at least tolerable but I am hardly a fan. I've already had to rebuild my ROG laptop twice because Win10 decided to corrupt itself.

Any thoughts on what I should to to try to get XP Pro to boot on my M8F? Seemed pretty straightforward..... I presume there's a setting in BIOS that I'm missing.

Win XP Pro is on a Maxtor sata HDD that came out of an Intel Bad Axe quad core 775 machine.

I can run Trucrypt on my new machine if I have to but since that sw is depreciated I'd prefer to go with bitlocker. These days, NOT encrypting one's system seems silly..... surprised no one here seems to be doing it, especially since ROG people tend to be on the cutting edge.

I was doing a little reading on bitlocker and to use that it seems you need to have a TPM module.

Scroll to specifications

Windows XP is listed at the Asus support center but there are no drivers.

The M8F mobo has no provision for installing a TPM module.

I understand that there are no drivers for XP.... but I'm not getting that far. At this point, a known good bootable HDD with XP Pro won't boot and the XP Pro install CD blue screens after loading a lot of software but before you get to the screen that allows you to do anything.