Showing results for 
Search instead for 
Did you mean: 

VIII Hero (and Ranger) broken HDMI output after BIOS 0802

Level 7

I have discovered the following issue after upgrading my BIOS from 0401 to 0802:

I have three Monitors connected to my PC - two to my MSI GTX970 and one to the Mainboards HDMI output.
With BIOS version 0401 it worked fine.
After upgrading to BIOS version 0802 the HDMI output doesn't work anymore, the monitor now only shows static. I got it to work under one condition - I have to define it as my primary monitor in the BIOS settings, then it works. If I set the primary display to PCIE (i.e. the GTX970) above issue arises.

Is this a known bug? I wasn't able to find any previous reports of this issue.

My setup:
Intel Core i7-6700K
ASUS ROG Maximus VIII Hero (also tested this with the RANGER, same issue!)
32 GB Crucial Ballistix Sport, DDR4-2400
MSI GTX 970 Gaming 4G


Hello Jaws_AT

Welcome to the ROG forum.

In the bios set the primary display to auto and enable multi monitor support if you have that feature.

Thanks for the warm welcome!

Multi monitor is enabled, otherwise it wouldn't work at all.
Setting primary to auto also shows the problem - and it DID work with the GTX 970 set as primary before upgrading the BIOS. I do not want to set HDMI as primary.


I think the Maximus VIII Gene mATX board also suffers from this.

I was really lost, struggling trying to do anything, had the board connected via HDMI to my TV, as I don't have a Display Port cable. I couldn't see anything at all.
I put in an old GPU connect ito a monitor via DVI and voila, instand screen of BIOSy goodness.

My Bios was Revision 0402 and wouldn't show the BIOS via the boards own HDMI out port.
Bit disconcerting on my 1st new build!

Flashed the BIOS to 0902 revision, and no dice, so definitely a board hdmi to TV issue.
However ASUS Maximus VIII Gene Z170 Skylake Motherboard still won't do HDMI out to my TV.
I used 2 cables, both work on this (old) PC, AND my Xbox 360, and both worked when connecting my new PC via my GPU's HDMI out.

Upon reading about the problems with 1001 I have yet to try that to see if they fixed this HDMI issue. Has anyone tried this yet?

BIOS 1001 also shows this issue.

I have reported this to ASUS in the meantime, they will forward it to their R&D department, let's hope they fix this in a future BIOS update.

Asus Level 2 support has concluded that this issue originates from a bug in the Intel display driver.

They've advised to use the following driver instead:

I can confirm that this new driver resolves this issue. Yay!

I am having the same kind of issue. I am using a MSI AMD 390 Gamer videocard on this board and using 2 monitors connected to HDMI and DVI connections. Via the DVI I am able to see bios and boot screen, via HDMI no boot screen. HMDI only gives a signal as soon as Windows loads.

I have switched off the onboard intel GPU and selected auto and PCIE on the bios, both give same problem. Also updated to latest 1010 bios and still having this problem.

This really is irritation since my HDMI is connected to my primary monitor which is a TV.

Level 11
My Hero seems to flash with both hdmi and display port and generally corrupt the screen randomly if the BCLK and multiplier are anything other than the defaults. XMP sets the bclk to 105.x and I even tried lowering the target GPU multiplier and it just doesn't seem to like anything that isn't the default.

This is prior to even getting into windows - the bios screen flashes randomly like I have a loose cable. Anyone else seeing this?