cancel
Showing results for 
Search instead for 
Did you mean: 

SonicStudio 2 not opening

brkkab123
Level 7
I just downloaded the most recent Realtek HD drivers from Asus for my Maximus VIII Hero on Friday. The driver is version 7829_20160630. SonicStudio is listed in Windows 10 Pro Anniversary Updates Start Menu, but it won't open.
I've uninstalled it and reinstalled the driver numerous times and it still won't open.
Any solutions are appreciated, as I'm still waiting for a response from Asus Support.
3,154 Views
3 REPLIES 3

Terepin
Level 8

brkkab123
Level 7
**SOLVED**Thanks Terepin. I got it working. Earlier I uninstalled the new Asus Realtek driver and installed one I knew it worked with. I then read your post pointing me to the other thread about it and got the Realtek driver from it and installed it through Device Manager. I didn't have to reinstall SonicSuite like the post stated. I restarted my pc after the driver update and SonicStudio 2 opened up and works.

brkkab123
Level 7
I'll bet I won't here from Asus Support until Wednesday, Thursday or Friday. I contacted them about something last month and it took 5-7 business day's to get a response back. Not good at all, especially for a R.O.G. product.