cancel
Showing results for 
Search instead for 
Did you mean: 

Sonic Studio won't open in WIndows 10 v1607

Terepin
Level 8
It starts in tray bar, but configuration window won't open. I'm gonna try newer version I found on the Internet.

EDIT: Nope, neither them work. Bummer.
EDIT2: This one work: http://dlcdnet.asus.com/pub/ASUS/misc/audio/Realtek_Audio_Win7-81-10_V6017629_Sonic_2216.zip?_ga=1.1...
154,329 Views
150 REPLIES 150

Nate152 wrote:
Hi guys,

I'm using the maximus viii formula and sonic studio II is working fine for me. What works for me is installing the realtek audio driver from the motherboard disc, sonic studio II installs with it.

If you try this be sure to uninstall your current realtek audio driver in programs and features.


U know that drivers from disc are outdated? Especialy Realtek ones

Nate152 wrote:
Hi guys,

I'm using the maximus viii formula and sonic studio II is working fine for me. What works for me is installing the realtek audio driver from the motherboard disc, sonic studio II installs with it.

If you try this be sure to uninstall your current realtek audio driver in programs and features.


Yes, old drivers work. The newer ones do not. And that's the problem.

When I'm trying to reinstall realtek drivers I'm stucking in restart loop. Assus support should do something with new drivers. It's simply pathetic.

I tried a couple of drivers from the ASUS VIII Hero list and driver version 7629 SS 2.2.16 works.

I am now able to open sonic studio and fiddle with the different features.

Does anyone know a source which can give me some good Equalizer settings? I don't like the presets and don't know enough to set a Custom profile.

With my old build there were some nice guides for Realtek but I can't find any for Sonic Studio.

Thanks.

xPepi wrote:
I tried a couple of drivers from the ASUS VIII Hero list and driver version 7629 SS 2.2.16 works.

I am now able to open sonic studio and fiddle with the different features.

Does anyone know a source which can give me some good Equalizer settings? I don't like the presets and don't know enough to set a Custom profile.

With my old build there were some nice guides for Realtek but I can't find any for Sonic Studio.

Thanks.


it doesn't seem to be wise to use older drivers and older software versions to solve this problem. BUT i did it for sake of testing... and guess what,, still can't run SS2

I think its something to do with Driver Signature thing that MS redstone version has implemented into their closed source windows.

AKBAAR wrote:
I think its something to do with Driver Signature thing that MS redstone version has implemented into their closed source windows.


If that would be the case all version wouldn't work.

Terepin wrote:
If that would be the case all version wouldn't work.

ya I think your right,

So I went to device manager and tried to force install the driver manually but nothing happened... hmm

Nate152
Moderator
yeah they may not be the most current but they work for me, when I let windows 10 update install the realtek audio driver sonic studio II wasn't even installed.

Nate152 wrote:
yeah they may not be the most current but they work for me, when I let windows 10 update install the realtek audio driver sonic studio II wasn't even installed.


But can you actually OPEN the Sonic Studio window and make any changes in there?

I too am having the same issue since the update. Using latest drivers from the MoBo page (I'm on a gene VIII).

Please sort this with an update ASUS