Showing results for 
Search instead for 
Did you mean: 

Sonic Studio won't open in WIndows 10 v1607

Level 8
It starts in tray bar, but configuration window won't open. I'm gonna try newer version I found on the Internet.

EDIT: Nope, neither them work. Bummer.
EDIT2: This one work:
150 REPLIES 150

matgalli wrote:
I quote the solution again, so that nobody have to search.

This Version comes from the Asus support after a angry email from me.
The official site of the Sonic Studio are the support site of every mainboard that have this sound features. eg.
I dont know why they dont speak to their customers!

Made an account just to come here and say thank you. This worked for me. The only thing slightly off is the notification when you plug or unplug something but functionally everything works great.

Still no official driver on the motherboard Support Page

xPepi wrote:
I installed 7910 and SS 2.2.28 and it works.

Thank you.

for some oddddd isuee on the lated yesterday nvidia drivers kill my os. So I format again all windows 10 current edition. Now i got automatic the supreme fx ROG automaticly install with audio driver with audio codec ALC1150. how i install SS 2.2.28 from the link SonicStudio2.2.28Realtek7904.rar cause i cant do it. is asking my email phone number etc like a malware think. How i can get the SS 2.2.28 with out changing the audio driver
Learn, Play Enjoy! We help and collaborate, NOT complain!

AKBAAR wrote:
This worked for me atlast... now i can pinpoint enemy coming from direction

Akbbaar i got he link. How did you install the SS with installing the old audio driver??? thanks!!!!
Learn, Play Enjoy! We help and collaborate, NOT complain!

Dear ASUS employee!

We need latest stable version of Realtek HD Audio and SONIC SUITE II. Please update MAXIMUS motherboards software and driver dl pages immediatly.... or give back our money cause u r unable to support your own products ! ! ! !

matgalli wrote:
Okay, I have a new Link:

1. uninstall the old driver! There is no AsusSetup in the rar-Archive. I have used the "old" AsusSetup from the last driver-package to uninstall while disabled Internet-connection, so Windows cant install driver by its own. After the windows-restart cancel the Installer.
2. install the Realtek Driver from the file-upload download
3. install SonicStudio from the file-upload download (open the setup as Admin)

Hey guys,
just checking if the above would work on my motherboard - maximus hero viii?


Im having this issue aswell, i would like official patch for this.

Difference is im Running Win 7 64Bitm realtek software will start but accesing sonic Studio just always comes up whit the "Programs has stopped" Error.

Edit: I have come up whit solution to this, its kind of stupid also. The solution lies under our eyes, looking at the drivers list at asus page for audio. Newest drivers simply dont Include the Sonic Studio, it does list so.


I still haven't found a way to get this to work properly. I am plagued by constant reverb from not being able to configure Sonic Studio.

matgalli wrote:
I got a new Version from Asus Support. But i cant't download it. The download starting with 100 KB/s and after 2 MB or so the download stops.

Does it work for you?

thank you sir

this worked for me

Hi guys,

I just recently upgraded to the windows 10 anniversary and sonic studio II is working fine for me.