cancel
Showing results for 
Search instead for 
Did you mean: 

Sonic Studio II low and high equalizer sliders have no effect

SoobRex
Level 7
Hello all, I have noticed in Sonic Studio that the 32Hz and 16kHz sliders have no effect on the sound output. All the other sliders work as they should. I am curious if anyone else has noticed this, and if so does anyone know how to fix? Using the most recent drivers from the ASUS website on Windows 10 version 1607. BIOS version 1902. Is there any way to get rid of Sonic Studio and still have an equalizer?
4,567 Views
9 REPLIES 9

Nate152
Moderator
Hello SoobRex

Welcome to the ROG forum.

It must be normal that's how it is for me too.

That's unfortunate. I really feel like my music is lacking without the highs. I expected better when I plopped down 400 bucks for this board. I've never really been impressed with the "supreme" audio. Anybody else noticed this behavior? Maybe someone can recommend a good third-party equalizer?

SoobRex wrote:
That's unfortunate. I really feel like my music is lacking without the highs. I expected better when I plopped down 400 bucks for this board. I've never really been impressed with the "supreme" audio. Anybody else noticed this behavior? Maybe someone can recommend a good third-party equalizer?


I stopped buying any ASUS ROG/Gaming boards because of this High end audio sucks and can't be fixed.
You can find my other post here and see that nobody here gives a rats ass about it as well.
Sad.

campb292
Level 7
N8LBV wrote:
I stopped buying any ASUS ROG/Gaming boards because of this High end audio sucks and can't be fixed.
You can find my other post here and see that nobody here gives a rats ass about it as well.
Sad.


Actually, those sliders work are working for me but I assume the software version has changed quite a bit since those posts from 2016. And for the record, the keyboard tuff stuff is lame. You didn't swear off ROG you bought a sound card lol. From your other thread here:

N8LBV wrote:
At the end of the day I just installed a sound card and was done with it.

That was my only choice other than to get a different motherboard model.

campb292 wrote:
Actually, those sliders work are working for me but I assume the software version has changed quite a bit since those posts from 2016. And for the record, the keyboard tuff stuff is lame. You didn't swear off ROG you bought a sound card lol. From your other thread here:


That was the last one I bought. "I stopped buying any ASUS ROG/Gaming boards because of this"


So yes and yes.

N8LBV
Level 7
The audio really is lame on these premium boards, I totally don't understand why they neutered the audio and notbody here since 2016 has offered any work-around or suggestions or pointed out anything I may be missing.

Other less boards like an old Z170-A have great audio and full EQ control.

Why make it suck like this? WHY?

N8LBV wrote:
I totally don't understand why they neutered the audio and notbody here since 2016 has offered any work-around or suggestions or pointed out anything I may be missing.

User error/incompetence. The equalizer works for me to.

ondersma80 wrote:
User error/incompetence. The equalizer works for me to.



Thanks for being a total jerk.
I hope you feel better when you do that.
It was not helpful.


And most likely it does not work for you more likely that you are deaf at high frequencies and don't know or can't tell the difference. 🙂

I'm not the only one out here reporting the issue.

Manish4586
Level 7
SoobRex wrote:
Hello all, I have noticed in Sonic Studio that the 32Hz and 16kHz sliders have no effect on the sound output. All the other sliders work as they should. I am curious if anyone else has noticed this, and if so does anyone know how to fix? Using the most recent drivers from the ASUS website on Windows 10 version 1607. BIOS version 1902. Is there any way to get rid of Sonic Studio and still have an equalizer?


Same for me with 4408 bios totally pissed off coming from asus b550m-a it was a geat motherboard compared to rog x570f the audio is total trash on x570-f, supremefx is a total lame thing i will never buy any asus rog boards i am done.
my home theater barely makes any bass with this x570-f whereas prime b550m-a gives punchy bass