cancel
Showing results for 
Search instead for 
Did you mean: 

PS4 Controller Bluetooth Issues (Z170 Motherboard)

MortimerScharf
Level 7
So, I'll go straight to the point. I have two PCs, both of them have an ASUS motherboard (albeit different models, the one I am currently using has a Z170 one), both of them have Windows 10, one of them has a Bluetooth Dongle while mine uses an antenna that's connected to the motherboard via three golden pins. I have two controllers, a PS5 Dualsense and a PS4 Dualshock one. Connecting the Dualsense to either of the computers was a piece of cake and took me less than ten seconds (and I got it working with all of my Steam games right away). However, getting the PS4 controller to work via Bluetooth is so hard, frustrating and difficult it's starting to become infurating.

If I connect the PS4 controller via a micro-USB cable, it works A-OK with no problems whatsoever. Whenever I try to connect it via BT, that's when the problems arise. The steps should be extremely simple, just like it was for the PS5 controller:
- Turn BT on.
- Press SHARE + Power button to enter pairing mode.
- Click "Add Bluetooth Device".
- Voila.

This is not the case for me though. Whenever I click "WIRELESS CONTROLLER" and it finally "pairs", said "WIRELESS CONTROLLER" instantly goes from "CONNECTED" to "PAIRED" in a matter of 2 seconds. The light on the back of the controller turns off after 20 or so seconds, too. I tried doing this via the "Bluetooth and other devices" settings menu, and through "Hardware and sound --> Add a device". Neither of those options have worked. I have:

- Reseted the controller using a safety pin.
- Uninstalled all HID drivers (and reinstalled them) by plugging the controller to my PC.
- I have uninstalled and reinstalled all BT drivers.

I know it's not a controller issue because I can connect it to my phone and it works like a charm, so it's Windows 10 throwing a tantrum. What can I do? I am really desperate at this point, and I have scoured Google in hopes of finding an answer to this question, but Google stops being useful after page 6. Help please!
1,612 Views
0 REPLIES 0