Showing results for 
Search instead for 
Did you mean: 

Maximus VIII Ranger (Z170) Flashing power LED while awake???

Level 7
A curious problem with my new ASUS Maximus Ranger VIII motherboard:

I've noticed that while the machine is powered up the power LED blinks constantly at a rate of about 1 per second. I can't find anything about this in the manual or using my Google-FU except that the power LED is only supposed to blink when the machine is in suspend mode or 'asleep'.

I have triple checked that the chassis power LED connection is properly connected to the motherboard power LED header.

During my extensive Google searches I did see ONE forum post from a few years ago that indicated that on many ASUS boards the power LED will blink like this is it detects abnormal voltage on one of the PSU rails, but I'm not seeing any other signs that would indicate this. Using software (I know, hardly accurate) all rails seem spot on and there really isn't any other outward signs that would seem to indicate a power problem. The Q Code LED readout also reads Ao once the system has fully booted which indicates no POST errors.

So far I've done the following troubleshooting steps:

1. Disconnected devices one by one from both the PSU and the motherboard, after each one I tried powering up - no dice. Still flashing power LED while running.
2. Completely disconnected the PSU and tried using another known good spare PSU. No dice.
3. Tried different RAM. No dice.

About the only things I haven't tried are:

1. Removing the motherboard from the chassis entirely and running it bare minimum on the bench.
2. Removing the Thermalright Ultra Extreme 120 and backplate and running with another CPU cooler. (thinking that the metal backplate could possibly be shorting against the bottom of the motherboard somehow and causing some kind of internal error code that manifests itself with a blinking power LED? Sounds like desperation, I know...)

It's really looking like the motherboard could be defective in some fashion - but aside from the blinking power LED I've (mostly) got it running stable..... mostly....


Asus Maximus VIII Ranger (Z170)
Intel Core i7-6700K
16GB (2x8GB) G'Skill DDR4 3000mhz
2x Crucial MX100 256GB SSDs (RAID0)
1x Seagate 2TB SATA HDD
1x LG 12X BD-R/RW (SATA)
1x Creative Sound Blaster Z PCIE 1x Audio card
Corsair 750 TX (750w) Power Supply

Level 7
Guess no one else is experiencing this issue?

Does anyone from ASUS even monitor these forums?

♪♫ I'm gonna keep on bumpin' youuuuuu.... cause it's the only thing I wanna doooooo ♫♪
♫♪ I don't wanna sleep, I just wanna keep on bumpin' youuuuuuUUUUU ♪♫

Level 7

Level 15
You should check your connections again. Make sure you've connected the cable to the proper header. Your problem makes me thingk that you might have connected your power button to the HDD activity LED.

Level 7
Thanks but:

1. I've triple and quadruple checked my front panel header connections as I clearly stated in the original post.
2. Connecting an LED to the HDD_LED activity indicator header wouldn't result in a steady 1 per second blink. HDD activity is a lot more sporadic and random than that. And furthermore since the HDD LED on my chassis is properly connected to the correct header on the motherboard I can watch the HDD LED light with corresponding hard drive activity WHILE the power LED is behaving in the aforementioned manner. The two LEDs and their behavior have zero correlation to one another.

Bump! Still going on, even with the latest BIOS.

I've even switched cases now... power LED still blinks at a steady 1 per second. This is so annoying....

Level 7
I would try another LED, or measure the output voltage on the mobo with a multimeter.