Showing results for 
Search instead for 
Did you mean: 

Maximus VIII Hero - no USB power on boot

Level 7
My PC starts up with no power to the USB devices. The problem does not occur every boot, more like half of the time. When the login screen for Windows 7 comes up, the USB keyboard and mouse have no power and do not function.

Additional info:
USB devices have power until the end of the "Starting Windows" logo, at which point they lose power and do not return.

Anyone else have this problem, or any ideas where I can look for the cause?

Mobo: Maximus VIII Hero (no overclock)
CPU: i7 6700K
RAM: 32GB (4x8) Corsair 2666
SSD: Samsung 840 EVO 250GB
PSU: Rosewill 1200 watt
OS: Windows 7 x64 Enterprise

Level 7
ddxfish.......I have this problem too. I posted on it last week. checking for a response now. Gabby

Level 7
ddxfish, I had 44 views... no replies. I did a little Google search,,, no real explanations. more like it is considered "acceptable".

ASUS is it acceptable to fail to have USB working at the login screen? (no mouse no keyboard) If so what happened?


Level 7
From the Hero download page, did you install the Intel chipset driver? And then the Intel USB driver?

I have installed the most recent chipset drivers from the drivers page as well as the most recent asmedia and intel usb drivers, all from Asus.

I tried this with a different keyboard and mouse.

I have tried this with and without AI Suite installed, with and without the USB turbo boost feature. I am not using any of the special programs like Ramcache.

I am trying to isolate the problem and get some more diagnostic info that is of use but its intermittent nature makes it difficult. It appears Prime 95 running right before a restart will increase the chances of the USB problem. I am leaning toward hardware issues perhaps, but I cannot rule out drivers.

Try changing XHCI hand off to ENABLED in the BIOS. It's under Advanced/USB config. Does that make any difference? I have a secondary drive installed with Windows 7 on my M8H and have not experienced this yet. I have however experience it on a Z97 Pro and understand the frustration.

If that doesn't work and no one else has a viable solution the sure fire way to correct it is moving to Windows 8.1/10 as they support XHCI/USB3 natively.

also have this problem. But only in BIOS. Sometimes i cant join Bios, cause del is not recognized or when i joined bios usb keyboard is not working. I have to Replug USB Keyboard.

My Personal Fix:
Installed Windows 10 UEFI Mode. USB Devices works anytime in OS. For BIOS i have to restart PC so often till usb work.

Setting xHCI handoff to enabled in the BIOS fixed the problem. I have not had it happen in about 2 weeks now.

Sorry for bumping this post, perhaps it will help someone else. Thanks SSD_Pro!