Showing results for 
Search instead for 
Did you mean: 


Level 9
Looks like this motherboard has this version up for download now. Given the debacle of the last BIOS, namely 3201, I've created this thread for people to share their experiences when upgrading to this new version. I personally am apprehensive to upgrade because of the issues I've had upgrading from 2202 to 3201. The WEI version issue most notably for me. Because of the 3201 upgrade, I had to take my motherboard back to the store and get it replaced with a new one.

So folks, have at it. Let's hear your experience with this version.

Please keep the discussion limited to the M8H only please.

Level 9
Hello, I'm having the same problem, just an FYI, I own the MAXIMUS VIII HERO, MAXIMUS VIII HERO ALPHA, and the MAXIMUS VIII FORMULA, I have updated to 3401 on the HERE ALPHA no problems, although I'm having an issue with running command rate of 1T with F4-3600C16D-16GTZR kit as I was able to with BIOS 2202, but no ME FW issue, with my FORMULA I am having the issue with the ME FW, I've tried FLASHBACK method and Easy Flash method with no luck, what happens is I do the FLASHBACK and then boot when its done, then it gets stuck at post code 7F, I let it be, it finally allows me to get into the BIOS and inside the BIOS it gives me ME FW, also the time it take to get into the BIOS is like 3-5min, and thats everytime I try to boot, I've never booted into Windows obviously cause there is something wrong, I just pulled the SATA cable from the boot drive, I was to get this sorted out first...

I have not yet tried to update the HERO board, I'm still on 2202, I will try tonight, does anyone have any thoughts on why my FORMULA is doing this? I'm also to go back to 2202 and everything works, and before anyway says just leave it alone, I'm a system builder for over 15 years, and I have a 7700K that will be going in it as soon as this gets figured out...

Hey Scorpion,

I had the same issue when I got the MEI error as well. It did take alot longer to boot into bios and longer to boot into windows. I don't know why this happened. Just a weird bug on the BIOS chip maybe? Anyways, the only thing you can do with that board, is take it in to the store you got it, and have it replaced or RMA.

I look forward to hearing your experience with the lastest bios update. 🙂

Level 9
it looks like BIOS 3401 is not available for the MAXIMUS VIII HERO, only 3201...taking the board back is not possible, as I purchased it almost a year ago, I believe its either how the update is processed, and not properly updating the ME FW, or some kind of faulty BIOS chip or incompatibility with the BIOS chip...I'm currently on hold with ASUS on the phone, but like I said my MAXIMUS VIII HERO ALPHA works fine on 3401 other than the memory timing issue, and I'm still on 2202 on the MAXIMUS VIII HERO and MAXIMUS VIII FORMULA...

I still can not get into the bios using my keyboard Logitech G510. The kayboard only works in windows 10 not during POST. Also after my pc wakes up from sleep mode non of my drives are active (HDD, SSD). There is something very wrong with this bios version.

Level 8
As I posted 4 days ago there is no 3401 FW for the M8H.

1.Improved System Performance
2.Modified OA key function in legacy OS
3.Fixed some PS/2 devices connection issue in win8/win10 when fast startup is enabled
4.Fixed chassis fan’s behavior after wake up from S3
5.Fixed CPU(i3-7350K) ratio item missing issue in SW

Level 7
Good Bios

Level 7
Updated just now. It works in stock at least.. I'm going to start reupping my settings now, since this firmware did not improve my experience with the RoG Spatha...

Level 8
Wish ASUS would get their act together with posting updates. They don't show up half the time. ASRock even has a better track record and that is pathetic!

They need to employ someone more reliable to update the descriptions and links.