cancel
Showing results for 
Search instead for 
Did you mean: 

Maximus VIII Formula, keep rebooting with 4 razer products connected.....

pt7272
Level 7
Greetings and thank you for reading my post, any advice is appreciated.

My issue is mind boggling, and I cant figure it out.

I build a new pc and hooked up 4 razer products { Firefly, Mamba, Tartarus, Deathstalker} all chroma.

My PC keeps trying to boot up and resetting when all 4 Razer products connected.

If I unplug any one of the Razer products it will load up, IF all 4 are plugged in it keeps trying to boot up.

I had the razer products in my previous build, Rog MAXIMUS IV EXTREME-Z and had no issues. In my Maximus formula VIII having this problem.

I currently have them plugged in to a USB 3.0 hub, I did test them plugged in directly to MOBO, and had the same problem.
2,427 Views
4 REPLIES 4

Nate152
Moderator
Hi pt7272

Maybe one of your devices is having compatibility issues with the z170 chipset, does each one work individually?

Check to see all devices have the latest firmware.

Do you have legacy support enabled in the bios?

Could also try a bios update.

UPDATE:

I pin pointed the problem, Its Wireless mice. I have 5 items plugged in to usb 3.0 hub, no issues.

When I plug in a wireless mouse ( I tested 3) PC will not boot up and keeps reseting.

I looked in BIOS can not seem to find any option from preventing this.

It could be related to USB keyboard and mouse emulation (found in the advanced tab of the bios, I believe). Either that or you are using a hub which draws power from the board and the wireless adapter is overloading it, have you tried it in a different USB port by it's self?

Yes I tried many tests.

Wireless mouse hooked up with any other 2 items in USB hub or directly to MOBO. Works Fine

Once you connect more then 3 items to hub or MOBO, this is when the problems start.

I have tested on 3 different USB 3.0 hubs.

I have tested 3 wireless mice, Spatha ( my new love 🙂 ...), Naga, Mamaba. All 3 problem exists when more then 3 items connected to PC or Hub.

Bios I only have Boot from Main SSD and DVD, nothing else.

I know its just something in settings that needs to be turned on/off, but mind boggling to figure it out.

Thank you for all the response btw 🙂