cancel
Showing results for 
Search instead for 
Did you mean: 

MAXIMUS VIII Extreme BIOS 3401 Thread

ratbone
Level 8
Just Released today for the Extreme motherboard:

I suspect this will be the last update for this motherboard but I could be wrong. I took the plunge to upgrade from 2202 to this version even though I have a Core i7 6700K



MAXIMUS VIII EXTREME BIOS 3401

1.Improved System Performance
2.Modified OA key function in legacy OS
3.Fixed some PS/2 devices connection issue in win8/win10 when fast startup is enabled
4.Fixed chassis fan’s behavior after wake up from S3
5.Fixed CPU(i3-7350K) ratio item missing issue in SW


I reset 2202 to default settings and upgraded without any issues
😄
368 Views
4 REPLIES 4

jab383
Level 13
I needed to put a Kaby Lake 7350K on the M8E today. By dumb luck, BIOS 3401 was there when I looked for the upgrade I expected for Kaby Lake. I did Clear CMOS and flashback. 3401 went in with no trouble and much appears to work as far as I've gone today.

The reason I need M8E when I have a M9Apex is not improved, though. Rats!

ratbone
Level 8
ratbone wrote:
Just Released today for the Extreme motherboard:

I suspect this will be the last update for this motherboard but I could be wrong. I took the plunge to upgrade from 2202 to this version even though I have a Core i7 6700K



MAXIMUS VIII EXTREME BIOS 3401

1.Improved System Performance
2.Modified OA key function in legacy OS
3.Fixed some PS/2 devices connection issue in win8/win10 when fast startup is enabled
4.Fixed chassis fan’s behavior after wake up from S3
5.Fixed CPU(i3-7350K) ratio item missing issue in SW


I reset 2202 to default settings and upgraded without any issues
😄


One day of use (mostly gaming) solid as a rock and no issues at all.

I have two things, which not work with this BIOS:
- I can save the OC-Setting. But then I load this Setting the Mainboard freeze and after a push on the resetbutton, nothing is changed.
- If I use the CSM-Settings for Windows 7 to aktive, save this Setting and after reboot I see only a black-Screen, but the Firmware runs and boot the
last OS. But I cannot Change any Settings in the Bios, because the screen is black. I tested it with the other Monitor-Ports but only one have an
Signal.

Can I use Windows 7 with CSM-Setting to deactivate?

Since Version 3XXX, where is a Setting callod advanced\Internal GOP configuration. What do this Setting and why this Setting not save, because after reboot this Setting have the Default value.

skybone
Level 7
Still "keyboard not detected if S5+S6 enabled. This red eye is staring at me with half the board lit at all times...

PS: Why was the rest of the Maximus VIII hero board not fitted with LED's? Seems foolish to only have the bottom half lit up.