cancel
Showing results for 
Search instead for 
Did you mean: 

Maximus VIII Extreme & Samsung 950 M.2

thboyes
Level 7
I didn't have any issues getting the Samsung 950 to be seen by the system, but it seems to be running slowly. I also have an 850 in the same machine, and it runs about the same speed.

BIOS settings? I'm not sure what to do. Top results are the 950, bottom is the 850.

Thanks,
thboyes

55931
10,965 Views
17 REPLIES 17

brkkab123
Level 7
Important:Is the Samsung 950 a M.2 ssd or a Sata 6 ssd. If it's a M.2 ssd, you can't use Sata ports 1 & 2. You'll need to have the 850 Pro in sata port 3.
Have you enabled Rapid Mode for it in Samsung Magician?
If you have Windows 10, have you restarted your pc 7 times without logging in until the 7th time? This speeds up everything Prefetch wise, which improves the performance.

Orici
Level 7
thboyes wrote:
I didn't have any issues getting the Samsung 950 to be seen by the system, but it seems to be running slowly. I also have an 850 in the same machine, and it runs about the same speed.

BIOS settings? I'm not sure what to do. Top results are the 950, bottom is the 850.

Thanks,
thboyes

55931


It looks like you have RAPID(or a RAMdisk enabled) with your 850 result. But the 950 looks to be low in IOPS, have you installed the samsung NVme driver?

Orici
Level 7
Here is my 950 m.2 with nvme:

@Orici
I do have Rapid Mode configured for the 850, and I do have the Samsung NVMe driver running.

@brkkab123
It is a NVMe drive, not SATA. It is Windows 10, and I'm sure I've rebooted it as you are suggesting.

@Chino
I don't mean booting, I mean general Windows performance. It's not horrible, just not any faster than the SATA 850 I'm using.

Thanks,
thboyes

thboyes wrote:
@Orici
I do have Rapid Mode configured for the 850, and I do have the Samsung NVMe driver running.

@brkkab123
It is a NVMe drive, not SATA. It is Windows 10, and I'm sure I've rebooted it as you are suggesting.

@Chino
I don't mean booting, I mean general Windows performance. It's not horrible, just not any faster than the SATA 850 I'm using.

Thanks,
thboyes


What BIOS version do you have?

Whitch SATA port is your 850 connected to?

BIOS 1402
The 850 is connected to SATA port 3.

thboyes wrote:
@Orici
I do have Rapid Mode configured for the 850, and I do have the Samsung NVMe driver running.

@brkkab123
It is a NVMe drive, not SATA. It is Windows 10, and I'm sure I've rebooted it as you are suggesting.

@Chino
I don't mean booting, I mean general Windows performance. It's not horrible, just not any faster than the SATA 850 I'm using.

Thanks,
thboyes


I wouldn't expect anyone to notice the difference in speed in general Windows performance. You'd need to do something really disk intensive or benchmarks to see the difference.

Do you have the 256GB version or 512GB version?

It's the 256GB version.

Where I notice the slowness it large file transfers. The speed is almost the same between the 950 and 850.