cancel
Showing results for 
Search instead for 
Did you mean: 

Maximus III Gene...a Pro and a Con

rchris
Level 7
The good news: Got my new Samsung 950 Pro M.2 SSD. Installation of Windows 10 on it was perfect with no problems. This thing is really fast! :cool:

The bad: I've now tried two different sets of RAM (2x8) and the motherboard fails to boot after selecting XMP in the BIOS. Also tried the TPU switch on the board, but same result.

Any suggestions? I'm doubting that it's a RAM issue after two sets, and suspect a MB issue. I did upgrade to latest BIOS (907), but got the same results.
2,846 Views
5 REPLIES 5

Chino
Level 15

The Maximus VIII Gene, v.1 with Intel i7-6700K (no OC yet). Samsung 950Pro M.2, 850EVO, and a WD Black 1TB for drives.
Memory models I've tried are:
G.Skill F4-3000C15D-16GTZB (2x8GB);
G.Skill F4-3000 C15D-16GRK

I know these were not on (at least the early) compatibility list. I took the risk because they were on a good sale, close to "approved" models (same timings), and I've never have trouble with XMP with past ASUS boards regardless of model numbers.

Is this board and/or DDR4 not as forgiving? Don't know if it's worth the cost to try an "approved" set.

Chino
Level 15

Thanks, I'll try that.
However, the 16GTZB set is TridentZ, not series 4, and it is on GSkill's compatibility list for the Maximus Gene. Seems like that set should have worked with XMP.

Chino
Level 15