cancel
Showing results for 
Search instead for 
Did you mean: 

M.2 disk disappears

JCvanDoorn
Level 7
Hi Everyone,

I have an ASUS Maximus VIII Hero motherboard with a Samsung SM951 (AHCI) 512GB m.2 disk as a secondary disk.
My primary disk is a Samsung 850 EVO 1TB. I run Windows 10 as an Operating System.

Everything works fine when I start my PC, but after a while of using it, the Samsung SM951 (AHCI) 512GB just disappears from my Disk Management. The only thing I can see in the event log is Event ID 157: Disk 1 has been surprise removed.

The strange this is, that when I put my PC in Sleep Mode and then wake it up, the disk is back again!

I've updated my BIOS to the Beta 902 version, but the problem is still there.

Does anyone else have this problem too?
Does anyone know how to resolve the problem?

Thank you for your help and best regards!
2,873 Views
1 REPLY 1

KozmoK
Level 7
JCvanDoorn wrote:
Hi Everyone,

I have an ASUS Maximus VIII Hero motherboard with a Samsung SM951 (AHCI) 512GB m.2 disk as a secondary disk.
My primary disk is a Samsung 850 EVO 1TB. I run Windows 10 as an Operating System.

Everything works fine when I start my PC, but after a while of using it, the Samsung SM951 (AHCI) 512GB just disappears from my Disk Management. The only thing I can see in the event log is Event ID 157: Disk 1 has been surprise removed.

The strange this is, that when I put my PC in Sleep Mode and then wake it up, the disk is back again!

I've updated my BIOS to the Beta 902 version, but the problem is still there.

Does anyone else have this problem too?
Does anyone know how to resolve the problem?

Thank you for your help and best regards!



I have the exact same issue! And the new 1001 bios does not help.