cancel
Showing results for 
Search instead for 
Did you mean: 

Keyboard not working, can't enter UEFI

davefellows
Level 7
I have a new system with a Maximus VIII Motherboard and for the life of me, I can't get the keyboard to work during boot. It's detected fine but F2/Del don't work to enter BIOS and occasionally, I get this wretched annoying message and can't move passed it:

After setting up Intel (R) Optane Memory or the RAID configuration was built, SATA Mode Selection must be changed to RAID mode to avoid unknown issues. Press F1 to continue and take advantage of ASUS optimized performance! If you wish to follow intel guidelines and apply its stock power limits, please disable the ASUS Multicore Enhancement (MCE) in the BIOS settings.

Next, you will enter the UEFI settings menu.


When I can actually manage to boot into Windows, the keyboard works perfectly fine! I've tried a BIOS update to 1007 but still the same issue persists. I've seen this issue mentioned by numerous other people but can't find a conclusive solution.

I completely perplexed that something as fundamental as a working keyboard is an issue with a top of the line motherboard in 2021!

Please help, I'm at a complete loss and are in fear of the next time it's going to go into this daft boot message and my machine will again be almost-bricked... I want to reattach my storage volume but I'm worried that will cause the above UEFI message again...

Thanks in advance!
Dave
3 REPLIES 3

BigJohnny
Level 13
What Keyboad? Some USB keyboards wont work in BIOS, they have to be booted and drivers loaded. One of the pitfalls of my corsair K100 keyboard. Best keyboard Ive ever had as soon as the OS loads but until then its useless. I Keep a spare core plugged in that does work sitting behind the PC if the need arises.

Hi Johnny, thanks for your reply. Good point re keyboard, hadn't thought a "standard" USB keyboard would have this issue. I have an older Gamdias Hermes keyboard which has separate USB and Audio connections. I wonder if there's a way to install the driver into the BIOS...

Alternatively, I might need to do your trick and have a second keyboard but that seems like unnecessary hassle...

Ha, well I just updated the firmware on my keyboard and it now works, yay! Thanks for the pointer Johnny! 😄