Z170
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

MAXIMUS VIII HERO - Sonic Studio - Crashing Firefox Flash Player

Bought new MAXIMUS VIII HERO, installed new win10, and all newest drivers from asus site, and problem is that "Sonic Studio" crashing Firefox Flash Player, all other browsers work fine.When Sonic Studio is off, Firefox flash player works fine without...

procc by Level 7
  • 4068 Views
  • 4 replies
  • 0 kudos

Maximus VIII Hero | Problem with Sonic Studio

Hi AllI installed SupremeFX Driver for Maximus VIII Hero Mobo. OS: Win 10 Pro x64Downloaded latest Realtek Driver from Asus Support.When I install Sonic Studio system becomes unstable.For example: Some apps give .exe errors and run very slowAlso som...

erkanco by Level 7
  • 8479 Views
  • 8 replies
  • 0 kudos

Maximus VIII Hero does not recognize Samsung 950 PRO M.2 NVME

Hello,i bought a new Asus Maximus VIII Hero and with it a new Samsung 950 PRO M.2 NVM Express. I installed the SSD in the M.2 slot but the motherboard does not detect it. I can not find the drive anywhere in the BIOS.I tried several things with the b...

N0va by Level 7
  • 45752 Views
  • 9 replies
  • 0 kudos

Maximus VIII Ranger slow boot times. (32.5 seconds)

I have an Asus Maximus VIII Ranger motherboard, 16GB of DDR 4 3200Hz RAM (G.Skill TridentZ series), and an Intel i7 6700K CPU. My boot times with a hybrid drive was on the average 32.5 seconds (this is from pressing power button on to de...

Asus Maximu Ranger z170 "d6" code strange problem

Hi Everyon. I have strange problem with ASUS Maximus RANGER Z170. Could you help me?Sorry for my englishMy new spec PCAsus rangerMSI gtx 1070 Armor OCram 2 x 8GB Corsair (QVL list compatible)When i boot my pc after first one beep there is 1 long and ...

ASUS Hero VIII DTS??

In the audio control panel, DTS shows up under digital only? Any way to enable that under analogue speakers??

Maximus VIII Impact - No POST, No Q-code, No Qled

Relevant build details:MB: Maximus VIII ImpactPSU: Silverstone SFX Series SX600-G 600WIssue: New build - I was not getting any Qcode or display or passing POST, and my BIOS flashback button slowly pulses blue.So; - I removed power - Removed my ram, ...

Asus Maximus VIII Hero help needed

I just built my new pc on Saturday and I'm having some serious issues with it.Issue #1: My download speeds on this pc are in the kbs., instead of the 111-115mbps I get from my i.s.p.Issue #2: Intel's Driver Update Utility fails to scanIssue #3: My Lo...

Maximus VIII HERO ALPHA - Onboard NIC + Surge = Bye Bye Nic

Currently my system main board is a Maximus VIII Hero Alpha which I only had for a couple of months. The other day lightening hit near the house causing a surge. The PC is perfectly fine as EVERYTHING in this house is on surge protectors. However lig...

CyberCub by Level 7
  • 5644 Views
  • 11 replies
  • 0 kudos

Realtek ATKEX issue

I had posted my problem at another forum trying to find out why this issue I am having is a problem. Nothing there so came here to see if I can get some answers. I have several Windows systems ranging from Windows 7, 8.1 and Windows 10Windows 10 is...

Denaba by Level 7
  • 7790 Views
  • 0 replies
  • 0 kudos