cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Z170 Gene strange memory issues...

sahafiec
Level 10
hi guys,

I have already red other topics about memory issues with this particular motherboard.
but my issue seems a bit different, thus I decided to open a new topic.
I'm using the Asus Z170 Gene (bios 1402), Intel i5 6600K (no OC) and Corsair 4x4GB 2400MHz ram (CMK16GX4M4A2400C14).

the motherboard and the ram are both in each others QVL lists so I expected them to work flawlessly.
the cpu, motherboard and ram combo is about 2 months old and I'm facing some random stability issues.
the range goes from a freeze to a BSOD, always random and not really reproducible.

I've been investigating that together with the great guys over at "tenforums" but was not able to find the real cause.
suspecting a driver issue I performed a clean install of my Windows 10 Pro so drivers should not be a problem anymore.
only a minimum of the only needed driver are cleanly installed: vga, audio and chipset (all up to date).

what I realize is that I never have a BSOD or freeze while running my rams on auto settings.
as soon as switch the rams to XMP and run them on 2400MHZ (instead of 2133MHz) I get random issues.
to be clear I never have issues to boot the system, the issues come later on and are not predictable.

additionally while troubleshooting the BSODs I ran a Memtest on the rams for more than 8 loops with no errors.
so there seems to be no physical issue with the rams but still XMP causes problems.

what's the problem with that motherboard, why is an overclocker motherboard not able to run 2400MHz ram on XMP?

the rams supports even 2666MHz on XMP (second profile) and the motherboard is advertised even with speeds up to 3800MHz.

I just don't get what's the bottleneck here, what's causing the issue?!

I appreciate any help I can get, especially by users of the same motherboard.

note:
for those interested hier is the link to my BSOD troubleshooting.
http://www.tenforums.com/bsod-crashes-debugging/40664-bsod-attempted_write_to_readonly_memory-window...
63,995 Views
156 REPLIES 156

hiong
Level 8
Try a slightly higher Dram voltage, 1.36 or 1.37v. And which RAM stability tests have you ran, and for how long each?

dannyboy292
Level 7
I ran mem test and HCI memtest and both passed with no errors.

dannyboy292
Level 7
I think I am just done trying to tweak this memory after almost 5 months of errors......Does anyone have and suggestion for tried tested and working memory that is not corsair that was made for z170 motherboards ?

sahafiec
Level 10
that's really weird, I had also issues with the same ram kit but my issues were not as severe as yours.
I usually got a crash or freeze within a week but not every day, no matter if on XMP or not.

if you have the issue on XMP as well as on SPD it could be something else.
did you check the cpu cooler and the socket pins?

Legolas
Level 9
Hi everyone, I saw new BIOS 1701 on Asus website. Did anyone try it and see if it is more stable with your mem spec?
Sincerely,
Legolas

dannyboy292
Level 7
So I moved the memory sticks from A2 and B2 and put them in A1 and B1 slots with xmp enabled (which I have done many times before) but not in bios 1701 , and I have not had any freeze ups or crashes since last night....I'll keep you posted on how it goes , and I may still pick up another set of ram as I noticed some kingston and gskill 16GB kits are on sale for well under a 100$ right now and see if they will run in the proper slots with xmp.

dannyboy292
Level 7
The problem came back 😞

sahafiec
Level 10
@Legolas
I did not see any difference after updateing to 1701, regarding stability.

@dannyboy292
that's bad but I almost saw it comming, some things seem to delay the crash but do not avoid it.
if you want to pick another ram choose one from the QVL list, just in case.
tha rams Nate152 suggested are very good but also not very cheap (at least on Amazon, newegg price is great).
this one could be a good alternative, it's on the QVL of my motherboard so just check yours:
HyperX FURY 2x8GB 2666MHz DDR4 CL15 DDR4 (HX426C15FBK2/16)
http://www.amazon.com/Kingston-Technology-16-PC4-19200-HX426C15FBK2/dp/B013H7QYEI?ie=UTF8&keywords=h...

sahafiec wrote:
@Legolas
I did not see any difference after updateing to 1701, regarding stability.

@dannyboy292
that's bad but I almost saw it comming, some things seem to delay the crash but do not avoid it.
if you want to pick another ram choose one from the QVL list, just in case.
tha rams Nate152 suggested are very good but also not very cheap (at least on Amazon, newegg price is great).
this one could be a good alternative, it's on the QVL of my motherboard so just check yours:
HyperX FURY 2x8GB 2666MHz DDR4 CL15 DDR4 (HX426C15FBK2/16)
http://www.amazon.com/Kingston-Technology-16-PC4-19200-HX426C15FBK2/dp/B013H7QYEI?ie=UTF8&keywords=h...


Yep. Kingston RAM has always been compatible and stable on ROG motherboards. I'm using that exact kit actually. 🙂