cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Z170 Gene strange memory issues...

sahafiec
Level 10
hi guys,

I have already red other topics about memory issues with this particular motherboard.
but my issue seems a bit different, thus I decided to open a new topic.
I'm using the Asus Z170 Gene (bios 1402), Intel i5 6600K (no OC) and Corsair 4x4GB 2400MHz ram (CMK16GX4M4A2400C14).

the motherboard and the ram are both in each others QVL lists so I expected them to work flawlessly.
the cpu, motherboard and ram combo is about 2 months old and I'm facing some random stability issues.
the range goes from a freeze to a BSOD, always random and not really reproducible.

I've been investigating that together with the great guys over at "tenforums" but was not able to find the real cause.
suspecting a driver issue I performed a clean install of my Windows 10 Pro so drivers should not be a problem anymore.
only a minimum of the only needed driver are cleanly installed: vga, audio and chipset (all up to date).

what I realize is that I never have a BSOD or freeze while running my rams on auto settings.
as soon as switch the rams to XMP and run them on 2400MHZ (instead of 2133MHz) I get random issues.
to be clear I never have issues to boot the system, the issues come later on and are not predictable.

additionally while troubleshooting the BSODs I ran a Memtest on the rams for more than 8 loops with no errors.
so there seems to be no physical issue with the rams but still XMP causes problems.

what's the problem with that motherboard, why is an overclocker motherboard not able to run 2400MHz ram on XMP?

the rams supports even 2666MHz on XMP (second profile) and the motherboard is advertised even with speeds up to 3800MHz.

I just don't get what's the bottleneck here, what's causing the issue?!

I appreciate any help I can get, especially by users of the same motherboard.

note:
for those interested hier is the link to my BSOD troubleshooting.
http://www.tenforums.com/bsod-crashes-debugging/40664-bsod-attempted_write_to_readonly_memory-window...
244 Views
156 REPLIES 156

Janne-71
Level 7
Strange, i had to increase the dram voltage from 1.35v (xmp setting) to 1.38 for comp to post with same memory (g.skill tridentz 3200). Perhaps it has to do with cpu overclocking?

sahafiec
Level 10
that's really weird how differently Skylake behaves, glad you solved it dannyboy292.
it seems there is no generall solution for everybody, each one must find his own solution.

TheRiwen
Level 7
@Sahafiec

Most there did have problems is people with corsair memory.

sahafiec
Level 10
that's a good point indeed TheRiwen, although I have no idea what the cause can be.
maybe the XMP profiles in the rams, maybe not.

Nate152
Moderator
I'll have to agree with TheRiwen corsair ram seems to be the most problematic with ROG z170 motherboards.

dannyboy292
Level 7
Well guys , my issue came back ..I am getting attempted execute of noexecute memory errors and crashes , memory access violations and when I run the Intel® Processor Diagnostic Tool I get a FAIL in big red letters when it is done even with everything at stock setting ....Any suggestions?

Nate152
Moderator
Try setting your ram manually instead of using XMP, sometimes this gives better results.

dannyboy292
Level 7
Just set it manually with the setting 16-18-18-38 with 1.35V @ 3200 and everything started up fine...going to play a couple games to see if the error comes back , I'll let you know how it turns out.

sahafiec
Level 10
@dannyboy292
your resent issues sound just like the ones I had all the time, except the FAIL on the IDT.
I hever had the cpu fail on the IDT and I have no real idea what could cause it.
what I would suggest is checking the cpu, cpu cocket pins and the cpu cooler.
even a very slightly overtightened cpu cooler can cause a lot of strange issues, same for a barely visible bent pin.
but Intel takes a cpu FAIL on IDT very seriously, I know this from the Intel forums.
it could be a legit reason for cpu rma, if needed.

the "attempted execute of noexecute memory and memory access violations" I know very well, I've spent months with them.
as Nate152 already said setting the ram manually could solve the issue but it could be also necessary to increase VCCIO and System Agent voltages as well.
after increasing VCCIO and System Agent voltages to 1.2V and DRAM to >1.25V my system didn't crash a single time.
no freezes no BSODs or whatsoever, I admit I changed the cpu as well, but I believe the voltages were the more important part of the solution.

I hope this helps you a bit to find some troubleshooting direction.

Nate152
Moderator
Hey dannyboy292

sahafiec is on the ball, if you still get errors try the vccio voltage and cpu system agent voltage at 1.20v.

You can set the Dram voltage to 1.40v if needed.