cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS Maximus VIII Ranger Worker Thread Returned at bad IRQL!!!

machineman
Level 7
Very weird BSOD when I boot from bootable windows 10 USB. IT shows the ROG logo and after that it gave me BSOD Stop: Worker_Thread_Returned_at_Bad_IRQL. I try with as few as possible components. Only mobo one piece of ram ,cpu and PSU with no luck. It shows me the same thing. I was having bios 3007. Use bios flashback to return to 2001. But again the same BSOD. I boot successfully from bootable memtest usb in uefi mode and it succeeded (weird cant boot from windows usb). I test ram with memtest with no errors. I googled about this error and try a lot of solutions with no luck.
Here is my system:

ASUS Maximus VIII ranger
i7 6700K
Cooler Master Vanguard 650
Cooler Master Hyper 612 Ver.2

I don't know what to do anymore.
2,912 Views
7 REPLIES 7

Legolas
Level 9
Did you make sure that your Windows 10 USB has drivers for the motherboard or just Windows 10 installer USB?
You can also check if 6700K installed properly and also the Hyper 612 has proper fan speed and have enough thermal grease.
Sincerely,
Legolas

Chino
Level 15

I try your suggestions with no result. I insert all drivers to windows boot image boot.wim, but again the same BSOD. I try clearing cmos, removing battery, swapping ram but nothing helped. I try to install via network (PXE boot) but again the same BSOD. Any other suggestions?

Chino
Level 15

I make bootable USB from original Microsoft CD Windows 10 Pro x86 and it worked. I also tried to make bootable USB from official Microsoft Windows 10 Education x64 ISO file but again the same BSOD. I checked the ISO with Microsoft FCIV and the SHA1 hash is the same as the one on the microsoft subscribers page so the ISO i use is not tampered. I don't know what is the problem. Is it Bios related (IMEI, cpu microcode). I found that is posible to clean ME from initialization data. Should i do that. I have bios 3007.

I successfully boot from windows 8.1 Pro x86. So i can boot from 32 bit operating system only. When i boot from 64 bit it shows me BSOD.

Can ME firmware in BIOS be replaced with newer one. In BIOS 3007 for my mobo the ME FW version is 11.6.10.1196 . There is newer one 11.6.20.1221