cancel
Showing results for 
Search instead for 
Did you mean: 

Asus ignoring ThunderboltEX 3 users? Asus official staff, please look here URGENT!

hoeman
Level 7
Hey Asus, this is an urgent and pressing matter that demands your attention. Let me first point you to this page regarding the supported boards for the ThunderboltEX 3. You can see that Maximus VIII Ranger and Z170-A are supported. However, I have tested this extensively and it seems Thunderbolt bios options were the right ones up until BIOS Ver 2202, when it still showed some information on the Alpine Ridge hardware. After 2202, i.e. 3007 and up, the Thunderbolt bios options changed and there is no configuration that actually allows the ThunderboltEX 3 card to work. This is preposterous. I know it's only a minority of users who use the Thunderbolt card, but you cannot possibly go ahead and include a non-functional Thunderbolt bios module for boards that are supposed to work with the card. I bought the board to use with the ThunderboltEX 3 card, I ought to be able to use it. Please fix this issue ASAP. My suspicion is that you guys ended up using the Thunderbolt bios module of later-gen boards on the Z170 boards, and even so, it is still a cut down version as it lacks the options that, say, the Z370-A has. For real, this has to be fixed. I'm stuck running 2202 which isn't a very good bios as it lacks the microcode updates and its DRAM compatibility is rather poor. Had to switch out my 3200 RAM for 2400 RAM and it still has issues booting from time to time. Ultimately left it at JEDEC specifications through manual settings and it's able to boot consistently.

FIX THIS!
3,443 Views
3 REPLIES 3

hoeman
Level 7
Hey Asus, you have a responsibility to us users to address such issues. This setup is supposed to work. The bios is defective. You've lost TB support from 2202 onwards. Please remedy the situation!

hoeman wrote:
Hey Asus, you have a responsibility to us users to address such issues.


This is a user-to-user discussion forum. ASUS does not provide official technical support here. A few ASUS people visit here and one of them may see your thread eventually but if you want immediate attention please call phone support.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

xxswakxx13
Level 7
Trust me, this is a lost cause. I just got off the phone with Asus 'Tech 3 Priority' Support (whatever that means) to RMA my second ThunderBoltEX 3 card and the rep specifically said:
There are no problems with the Asus ThunderBoltEX 3 Card. We have not heard of, or know of any issues with the card.
I asked, "Have you looked online in any forums? There are issues being reported everywhere. I'm having to send my 2nd card in for RMA in the span of 2 months."
Asus rep response: There aren't any problems being reported with the Asus ThunderBoltEX 3 Card, but thank you for bringing this issue to our attention.

Worst part of the RMA, because the card was included with my X99 Deluxe II purchase, they require I send the motherboard in as well for testing. I just got my motherboard and thunderbolt 3 card back from repair from the previous RMA 3 weeks ago, and now I have to send it in again.

Thanks Asus.