cancel
Showing results for 
Search instead for 
Did you mean: 

2x8GB or 4x4GB DDR4 kit for Ranger?

yamatosan
Level 8
I forgot the basic rule of researching/thinking before buying and I've made a mess.
When I bought my components for my new rig back in december 2015 I did not think about memory too much.
I bought the best priced and high frequency money can buy at that moment, a 2x4GB kit : HyperX HX426C15FBK2/8
I was thinking that I will get later on a similar kit and upgrade to 16GB, but I remember later on "meat and potato" rule:
"DO NOT USE ONE KIT OF MEMORY OF 2x4GB (MY CASE) TO HAVE 8GB, THINKING LATER ON I WILL GET AN IDENTICAL KIT OF MEMORY AND HAVE A TOTAL OF 16GB, ESPECIALLY IF YOU PLAN TO OVERCLOCK. INSTEAD USE ONE BIG KIT OF 16GB, EITHER 2X8GB DUAL CHANNEL OR 4X4GB QUAD CHANNEL, BUT MAKE SURE THAT THEY ARE INTENTED FOR YOUR PLATFORM (Z170 IN MY CASE) !!!."
I manage to get 2 identical kits to work together, made tests and no errors appear with HCI & Memtest, but they are stable only at stock speed of 2133MHz. I'm sure that someone can spend a lot of time to tweak 2 identical kits to work together and maybe succeed, but I do not plan to do that.

So now i need to sent back 1kit of 2x4GB and get a new kit of 16GB.
My options for 2x8GB kit are following:
1. Corsair Vengeance LPX Red CMK16GX4M2B3000C15R with 15-17-17-35@1.35V
2. Kingston HyperX Savage Black HX430C15SB2K2/16 with 15-17-17-??@1.35V

My options for 4x4GB kit are following:
3. Corsair Vengeance LPX Black CMK16GX4M4B3000C15 with 15-17-17-35@1.35V
4. Kingston HyperX Savage Black HX430C15SBK4/16 with 15-17-17-??@1.35V


CMK16GX4M4B3000C15 (4x4GB kit) is the only one in QVL list.
Let me know what should I buy.
14,251 Views
30 REPLIES 30

Nate152
Moderator
Hello yamatosan

2x8GB will put less strain on the cpu's IMC, go with any of the first 2 with the color you like or whichever is cheapest.

yamatosan
Level 8
Hi Nate. This will be my choice too. 😄

Chino
Level 15
If I had to pick between the two 2x8GB kits, I'd choose the Kingston HyperX Savage Black HX430C15SB2K2/16 kit. I've been using their products for quite a while now and I've never ran into any issues with performance, stability or compatibility. 🙂

Chino wrote:
If I had to pick between the two 2x8GB kits, I'd choose the Kingston HyperX Savage Black HX430C15SB2K2/16 kit. I've been using their products for quite a while now and I've never ran into any issues with performance, stability or compatibility. 🙂


I got a call today and surprisingly seller asked me to confirm what product I want to replace already return kit.
And I opted for Savage 2x8GB :p. Now i need to wait for confirmation and some days to receive the package.

yamatosan
Level 8
Corsair costs 112USD, HyperX costs 137USD. Not a big difference, but I already sent back memory kit and I opted for Corsair.
Anyway, now comes the hustle to return memory kit back, to be accepted by the seller and to buy the new one 😞
I used the sticker inside the package :rolleyes:

yamatosan
Level 8
I got my new kit yesterday and today i got time to upgrade. Bios was updated earlier at 1504.
I cleared CMOS from board button and restart the computer.
Got into bios and memory kit was visible. but at 2133Mhz (DRAM voltage on auto 1.200V).
I checked CPU System Agent Voltage and value indicated was 1.072V [I noted this one for later use].

[my XMP DDR4-3000 overclock settings]
Changed AI Overclock Tuner from Auto to XMP and choose my XMP profile: XMP DDR4-3000 15-17-17-39-1.35V.
BCLK Frequency became 100.00 and DRAM Frequency became DDR4-3000Mhz. DRAM Voltage was set to 1.3530V.
Even if my input value was 1.35 bios register as value 1.3530 as voltage. Can't argue with that.
Rest of voltages stayed on auto (CPU Core/Cache, CPU VCCIO, CPU System Agent, PCH Core and CPU Standby).

Saved configuration and reset and got a beautiful Q-code 55 [memory not installed]. Shutdown computer and PSU. Removed both memory and reinstall them. Power my PSU and start computer again (code A0 = good). Overclock Failed and press F1, no worry. Booted with DRAM at stock speed 2133, got into win7 x64bit and ran realbench just for fun (@2133 with timings 15-15-15-36-2T @1.2V). Passed benchmark and stress test for 15min with 16GB RAM, again just for fun. Restart to get into bios and my XMP DDR4-3000 overclock settings are still there. So I change only CPU System Agent Voltage from Auto to 1.220V, based on the fact that bios indicate me 1.208V, so I need to add only +0.010V. Saved configuration and reset. Overclock failed again and press F1.
Got back into bios and changed CPU System Agent Voltage to 1.083V. Bios register as value 1.08750V and saved and reset again. I did this by adding +0.011V to my initial CPU System Agent Voltage noted at stock speed (@2133 voltage was 1.072V).

And it worked. And manage to install Kingston HyperX Savage Black HX430C15SBK4/16 with 15-17-17-39 2T @1.35V


Nate152
Moderator

yamatosan
Level 8
False alarm Nate. When tested with hci memtest i get error.
I use 4 instances with 2047MB as i have 4 threads available.
With memory kit at stock speed 2133Mhz bios says i need 1.072V.
Having XMP profile set and DRAM voltage set to 1.3530V (which is correct due to increment use by bios) i set CPU System Agent Voltage and i get:
Code 55 @ 1.0750 1.0875. 1.1000 1.1250 1.1375 1.1500 1.1625 1.1725
Code 35 @ 1.1125
Code 41 @ 1.2125
OS boot @ 1.1875 1.2000 1.2250 but with error on hci memtest under 15% coverrage with 4 threads

Nate152
Moderator
Ahhh shucks !

well you almost have it, raise them a little more.


vccio voltage - 1.20v - 1.25v
cpu system agent voltage - 1.25v

How does she go now?

If it still gives you errors raise the Dram voltage to 1.38v - 1.40v